Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't install HP printer/scanner on Dell computer


  • Please log in to reply

#1
VinnieD711

VinnieD711

    New Member

  • Member
  • Pip
  • 2 posts
Hello, and thanks in advance!!!

BRIEF SUMMARY OF PROBLEM:
I cannot install the software for my HP Printer on my new Dell computer. When I try, I get a window saying that there is already a more recent version of this software installed on my computer, so the window closes out. When I plug the USB cable from my device into my computer to try to get just a plug-and-play recognize, the Found New Hardware Wizard opens, goes through a series of processes, and then closes after displaying a message about not being able to connect to the device.

DEVICES INVOLVED:
Printer- HP2355 (Hewlett Packard All-in-one Printer/Scanner/Copier)
Computer- Dell XPS710

SUMMARY OF SYSTEM INFO:
OS Name Microsoft Windows XP Professional (w/ Windows Media Center 2005)
Version 5.1.2600 Service Pack 2 Build 2600
OS Manufacturer Microsoft Corporation
System Name withheld for security purposes
System Manufacturer Dell Inc.
System Model Dell XPS710, Intel Core2 CPU (6300 @ 1.86GHz), 1.00 GB of RAM
System Type X86-based PC
Processor x86 Family 6 Model 15 Stepping 6 GenuineIntel ~1862 Mhz
Processor x86 Family 6 Model 15 Stepping 6 GenuineIntel ~1862 Mhz
BIOS Version/Date Dell Inc. 1.1.0, 12/7/2006
SMBIOS Version 2.3
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "5.1.2600.2705 (xpsp.050622-1524)"
User Name withheld for security purposes
Time Zone Eastern Standard Time
Total Physical Memory 1,024.00 MB
Available Physical Memory 563.85 MB
Total Virtual Memory 2.00 GB
Available Virtual Memory 1.96 GB
Page File Space 2.40 GB
Page File C:\pagefile.sys

ELABORATION OF PROBLEM:
I bought a new Dell computer in January of 2007. When I went to install the printer on it (first step according to HP is to install the software), the Autoplay ran for the CD. The “HP All-in-one-Series” message box goes through a series of splash screens and ends up with the final message “A more recent version of software for this product is already installed on your computer. Simply connect the device to your computer and the software will automatically recognize the device.” The only clickable button is FINISH, so I click it and both HP windows close.

I then opened Control Panel→ Add/Remove Programs → HP All-in-one product, then uninstalled it. I went to Start→ Printers and Faxes, then selected and deleted the HP2355 printer. I restarted the computer and tried to run the software CD-ROM again: the exact same thing happened.

I went to hp.com and located & downloaded the most-recent version of this software. I downloaded and unzipped it successfully, but when I went to run it, I got the exact same behavior as described above, with the same end result.

At this point, I called Dell. The technician had me download and install their “Remote Access” tool and took control of my computer. He made several attempts to install the software, but they all failed. He also made several adjustments to the registry, as well as downloaded and ran some Clean-up tool.

After an hour or so and no resolution, he said that there was nothing else that he could do. His suggestion was that I wipe out the hard drive and reload the operating system and then try to install the printer. I was speechless, as this is not even an option for several reasons- namely, this is a brand new computer that costs more than I wanted to spend- if it came out of the box loaded up with exactly what is on the backup CDs that they sent me, which presumably it did, then what possible difference would there be? he thought that maybe some of the drivers or config settings transferred over from the old computer. Not possible- I purposely didn’t use the Files and Transfer settings wizard- I installed NetSupport on both computers and copied files & documents (ONLY) from the old comp and brought them over to the new via a crossover cable; also, the printer/scanner/copier was about $280 and is only about a year old- buying a new device is just not an option, as this one works great; finally, several message boards, as well as the technician himself, stated that there are known issues with installing peripheral devices on dell computers. Another reason is that I wiped out my ‘old’ computer files after I transferred them over to my new computer. I would have to transfer from new comp to old one, wipe out new one, then transfer everything back over and set it up again. It took me five days to do it the first time- I am not doing it again. Regardless, as mentioned above, this printer installed and worked just fine and without incident on my previous (Gateway) computer.

After speaking with the Dell tech, I decided to run some tests-
1) Since I still have my old, ‘naked’ computer (O.S. and programs only- all files deleted). I uninstalled/removed the previous (working) version of the HP software and restarted the comp. When it came back up (printer USB not plugged in) and I inserted the HP software, the normal splash screen came up and said “Welcome to the Install Wizard for HP All-In-One Series” and I was able to click NEXT. When I did, I ran for several seconds and then brought me to the next step, Installation Options (radio buttons = Typical or Minimum). At that point, it is obvious that the software is properly installing and I click CANCEL.
2) On my parents’ 1997-Home-Shopping-Channel computer, also with Windows XP (Home Edition; mine is XP Pro), I uninstalled then unplugged my dad’s printer. I restarted computer. When it rebooted, I put in the [same] HP software CD. I got as far as I did in #1 above: it worked fine. I reinstalled dad’s printer.
3) On my work laptop that I bring home on weekends, an IBM ThinkPad (also with XP Pro), I inserted software and got all the way to the point I did for #1- it also worked fine.

I had tried to call HP initially (before Dell), but got a message that without paying a fee that I could only chat w/them or email. Tried to setup a chat session (four times), but was never able to get through- the next step is to email them to see if they have any suggestions, or if this is a known issue, but it logically concludes that if I can get their software to install on 3 out of 4 machines, that the responsibility would be on Dell to help provide a (viable and realistic) solution, not HP.

I also did a little registry editing- I removed all keys that I could conclusively determine were HP-related. I did the same for AOL (the Dell tech said that it was known to cause problems. I never had it installed and it was not in the Add/Remove Programs List, yet there were several registry keys for it). After restarting (I set a restore point prior to making the adjustments, just in case) and re-trying to install the software, I get the same response saying there’s already a newer version.

Anyway, sorry for the lengthy description, but I just wanted to make sure I got all the important stuff in. I would truly appreciate any help that you could provide, as I have run out of options and patience at this point. Let me know if you have any questions.

Vinnie
  • 0

Advertisements


#2
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
01-VinnieD711-[HP2355 All-in-One-Printer] 25th FEB-2007

Hi VinnieD711 – Welcome to – Geeks to Go

Just a quickie item that I just recently was shown – May not apply to you – it is worth looking at – It depends if you have the DEP – Data Execution Prevention – Option on the – Advanced Tab – in the – My Computer Property Folder – See link below for info – [Some retail installed XP will not apply] -

DEP – Data Execution Prevention for Windows 2000 XP – Service Pack 2
http://support.microsoft.com/kb/875352

Do the one of the following – if applies - Option 1 or Option 2 -

OPTION 1. – [For Home Users]
Right-click My Computer and select Properties.
Select the Advanced tab
Under Performance select Settings
Select Data Execution Prevention tab
Select "Turn on DEP for essential Windows programs and services only."

Reboot and it should work. Worked for me anyway.

--------------------------------------------------------------------------------
OPTION 2. [For IT Professionals with network]

1. Right-click on My Computer, and select Properties.
2. Click on the Advanced tab.
3. Under Performance, click Settings.
4. Click the Data Execution Prevention tab.
5. Select the Turn on DEP for all programs and services except those I select: option.
6. Click Add....
7. Browse to C:\WINDOWS\system32\spool\drivers\w32x86\3\hpzeng07.exe and click Open.
8. Click Apply.
9. Click OK, and OK again.

Jack123

Edited by Jack123, 25 February 2007 - 05:41 PM.

  • 0

#3
VinnieD711

VinnieD711

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Jack123-

Thanks for the suggestion and for getting back to me so fast. I read your post and went to the linked Microsoft website. When I go to C:\WINDOWS\system32\spool\drivers folder, there is no folder named w32x86. There are only folders called Angel2, disdn, etc, and UMDF. I searched for hpzeng07.exe, but there was no return- I'm pretty sure I deleted it in one of my sweeps. Any other thoughts?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP