Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

unknown device


  • Please log in to reply

#1
zendude

zendude

    New Member

  • Member
  • Pip
  • 2 posts
Installed Vista Ultimate and have "unknown device" error listed on my device manager. Can't resolve issue.

Zendude
  • 0

Advertisements


#2
BluePoet

BluePoet

    Member

  • Member
  • PipPip
  • 47 posts
Do you have a Creative X-Fi card? Microsoft seems to have declared war on these, and even though I have the updated, non-beta driver from Creative's website, it is still listed as unsupported. Fortunately, my mobo has on-board 7.1 sound. Hope yours does, too, if this is the problem.
  • 0

#3
zendude

zendude

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
BluePoet:

Thanks for the response. I have a Evga nForce 4 7800 GT card. I'll check the Evga website for possible solutions.

Cheers,

Zendude
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP