Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Help! SSL is broken and no secure sites will load!


  • Please log in to reply

#1
Jedilaw

Jedilaw

    New Member

  • Member
  • Pip
  • 4 posts
Hello all,

This is my first post here. I have attempted to search for similar questions, but have found none. I apologize in advance if what I am asking has already been answered.

At any rate, here is my problem: SSL support seems to be broken on my computer. The problem came to my attention when iTunes refused to let me sign in for a purchase, because it said I did not have SSL 3.0 enabled. The thing is, I checked my Internet Options in Control Panel, and under Advanced Options SSL 2.0 and SSL 3.0 are both checked as active.

This is what iTunes said:


Microsoft Windows XP Professional Service Pack 2 (Build 2600)
TOSHIBA Satellite P105
iTunes 7.0.1.8

Current user is an administrator.

Network Adapter Information

Adapter Name:	{[b]redacted[/b]}
Description:	Intel(R) PRO/Wireless 3945ABG Network Connection - Packet Scheduler Miniport
IP Address:	0.0.0.0
Subnet Mask:	0.0.0.0
Default Gateway:	
DHCP Enabled:	Yes
DHCP Server:	255.255.255.255
Lease Obtained:	Mon Feb 26 08:49:41 2007

Lease Expires:	Mon Feb 26 09:49:41 2007

DNS Servers:	

Adapter Name:	{[b]redacted[/b]}
Description:	Intel(R) PRO/1000 PL Network Connection - Packet Scheduler Miniport
IP Address:	192.168.100.78
Subnet Mask:	255.255.255.0
Default Gateway:	{[b]redacted[/b]}
DHCP Enabled:	Yes
DHCP Server:	{[b]redacted[/b]}
Lease Obtained:	Tue Feb 27 16:04:47 2007

Lease Expires:	Wed Feb 28 00:04:47 2007

DNS Servers:	10.10.20.11
		10.10.20.12

Network Connection Information

Active Connection:	LAN Connection
Connected:	Yes
Online:		Yes
Using Modem:	No
Using LAN:	Yes
Using Proxy:	No
SSL 3.0 Support:	Enabled
TLS 1.0 Support:	Enabled

Firewall Information

Windows Firewall is on.
iTunes is enabled in Windows Firewall.

Connection attempt to Apple web site was successful.
Connection attempt to iTunes Store was successful.
Secure connection attempt to iTunes Store was unsuccessful.
A secure network connection could not be established.

I then tried to go to my bank website, and could not log in (the splash page loads, but once I input my user info and the site tries to redirect to the secure servers, it won't load). Yahoo mail won't load at all, and Turbotax loads the splash page but kicks me out once I input my user data and the site tries to go secure. :whistling:

A brief summary of my system:

Toshiba Satellte P105 S9312
Intel Core Duo 2GHZ
2GB DDR2
Nvidia 7900GO

Browser: Firefox 1.5.0.10
OS: Win XP Pro SP2
Antivirus: Avast (weekly sweeps, no viruses found)
Anti-Spyware: Webroot Spy Sweeper (weekly sweeps, no adware or spyware found)
Firewall: Windows Firewall, plus the firewall on my work connection (I seldom log into the net from this laptop at home).

If anyone had any thoughts or advice, I'd really love to hear it. This problem is a no one for me, as I've never even heard of SSL spontaneously ceasing to function. To my knowledge (and I've Googled this several ways) there are no diagnostic apps to find SSL-related problems, nor are there any downloads to restore SSL functionality. I tried looking for site certificates, and found...none. So I can't purge whatever bad certificates.

Please advise, if you have a moment or two.

Thanks in advance,

Jedilaw
  • 0

Advertisements


#2
techie4fun

techie4fun

    Member

  • Member
  • PipPip
  • 51 posts
If you have SSL enabled and aren't having luck, try changing your cookie settings so that your browser accepts the cookies from the websites that your trying to log in through securely.

Edited by techie4fun, 28 February 2007 - 09:49 AM.

  • 0

#3
Jedilaw

Jedilaw

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts

If you have SSL enabled and aren't having luck, try changing your cookie settings so that your browser accepts the cookies from the websites that your trying to log in through securely.


Firefox is set to accept cookies, still no dice. And how would cookies affect iTunes, which isn't a web browser (or is it)?
  • 0

#4
Jedilaw

Jedilaw

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
I would sincerely appreciate it if someone would take a look at this issue. :blink:

I have used System Restore to go back two weeks, to when I was able to access these things, with no luck. I have cleared my SSL certificates, hoping that new ones would be installed to fix it (by going to the protected sites). I have cleared my browser cache. Still nothing. :whistling:

This problem is entirely perplexing to me. Does anyone have any suggestions in addition to enabling cookies? :help:

Thanks,

JL
  • 0

#5
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Since you're using FF, make sure you have the latest version which just came out. Then go again to Internet Options in Control Panel and add the sites to your Trusted zone under the Security tab (https only). Under Privacy tab, put slider to Medium High if not there already. Make sure none of the sites are being blocked by checking list (click Sites button). Under Connections tab, your Lan settings should be set to automatically detect settings. Might trying setting everything to the Default setting on the Advance tab. Try rebooting after this if necessary.

Can you explain more about iTunes connection? Aren't you using either IE or FF browser window or is it going to the iTunes store from within Windows Media Player or its own player?

Ron
  • 0

#6
Jedilaw

Jedilaw

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts

Since you're using FF, make sure you have the latest version which just came out. Then go again to Internet Options in Control Panel and add the sites to your Trusted zone under the Security tab (https only). Under Privacy tab, put slider to Medium High if not there already. Make sure none of the sites are being blocked by checking list (click Sites button). Under Connections tab, your Lan settings should be set to automatically detect settings. Might trying setting everything to the Default setting on the Advance tab. Try rebooting after this if necessary.

Can you explain more about iTunes connection? Aren't you using either IE or FF browser window or is it going to the iTunes store from within Windows Media Player or its own player?

Ron


iTunes goes to the store from within its own player. It may use HTML code, but it's not piggybacked on any browser I know of.

I have uninstalled Firefox, disabled SSL 2 and 3, re-started, re-installed Firefox (latest version), re-enabled SSL 2 and 3, and restarted, still with no luck.

What I don't get is why using System Restore didn't restore the flipping certificates.

This is getting reeeealllllly friggin' aggravating...
  • 0

#7
Fenor

Fenor

    Trusted Tech

  • Retired Staff
  • 5,236 posts
You might want to check out the follow website and see if it helps your situation at all.

http://www.technipag.../article26.html

Fenor
  • 0

#8
happyrock

happyrock

    Tech Moderator

  • Retired Staff
  • 9,285 posts
you may also want to check that your firewall isn't causing the problem
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP