Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Can't connect to the iTunes Store

  • Please log in to reply

Jason M

Jason M

    New Member

  • Member
  • Pip
  • 2 posts

For the past two weeks I have been unable to connect to the iTunes store. I have removed my Norton Internet Security and downloaded the most recent version of iTunes (7.1). Still, whenever I tried to connect I get the following message:

"iTunes could not connect to the iTunes store. The network connection was refused."

I ran the diagnostics and got the following results:

Microsoft Windows 2000 Professional Service Pack 4 (Build 2195)


Current user is an administrator.

Network Adapter Information

Adapter Name: {F1EC85D5-26DC-4D19-9ECF-609E3665BE5A}
Description: Belkin Wireless G Notebook Card
IP Address:
Subnet Mask:
Default Gateway:
DHCP Enabled: Yes
DHCP Server:
Lease Obtained: Fri Mar 09 00:06:29 2007

Lease Expires: Mon Mar 12 00:06:29 2007

DNS Servers:

Network Connection Information

Active Connection: LAN Connection
Connected: Yes
Online: Yes
Using Modem: No
Using LAN: Yes
Using Proxy: No
SSL 3.0 Support: Enabled
TLS 1.0 Support: Enabled

Firewall Information

Connection attempt to Apple web site was successful.
Connection attempt to iTunes Store was unsuccessful.
The network connection was refused.
Secure connection attempt to iTunes Store was unsuccessful.
The network connection was refused.

This is becoming very frustrating. Any help would be greatly appreciated!! Thanks.

Edited by Jason M, 08 March 2007 - 11:56 PM.

  • 0





  • Member
  • PipPipPip
  • 693 posts
Start > Internet Explorer > Tools > Options > Connections > LAN Settings > *TICK* Automatically Detect Settings > Try again.
  • 0

Jason M

Jason M

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
The "Automatically Detect Settings" option was already ticked. Regardless, I unticked and reticked it and tried connecting again, but still got the same message.

Any other thoughts?
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP