Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Front USB Ports/Drivers not working


  • Please log in to reply

#1
k_buddy86

k_buddy86

    Member

  • Member
  • PipPip
  • 13 posts
Hi,

Excuse my lack of knowledge for computer jargon, but the 3 USB ports I have at the front of my computer tower are not working/responding. How can I fix this problem?

Thanks!!
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Take the side of the case off, follow the cable from the ports to where they plug into the board.

Rather than spend time typing, I thought this might be better:
http://www.directron...installusb.html
  • 0

#3
k_buddy86

k_buddy86

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
Thanks Neil!

But I don't think the problem is the actual cable connection of my USB ports to my motherboard...but rather the drivers for the USBs have stopped working?

Do I make any sense?
  • 0

#4
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Windows uses the same drivers for all USB ports regardless of how they're connected. Therefore you should isolate the issue further by determining whether its just the front USB that doesn't work or all the USB ports that don't work. Obvious way to do this is to take something you usually plug in the front and plug it in on the back and see if you can then use it. If so, the problem is exclusively with the front ports.
  • 0

#5
k_buddy86

k_buddy86

    Member

  • Topic Starter
  • Member
  • PipPip
  • 13 posts
the back ports work because my speakers and printer are connected to them...i think it's just my front ports, any help please?
  • 0

#6
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Assuming the front panel wiring is correct, some boards have more than one set of take-offs for front USBs to connect to. With no more details I cannot be more accurate, I'm afraid.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP