Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Search bar conflicts


  • Please log in to reply

#1
stang

stang

    Member

  • Member
  • PipPip
  • 43 posts
I have a part of my index page split into two cells and in one cell I have a lyrics search bar and in the the other one I have video search bar. They use to work fine until I added some new content and now when I press the video search button it opens the lyrics search page. Any help on how to resolve this conflict would be great. Also the same thing happens when I try to add my paypal donate button.
  • 0

Advertisements


#2
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
A link to your site would be helpful.

Ron
  • 0

#3
stang

stang

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Sorry, www.stang.us

Edited by stang, 30 March 2007 - 06:27 PM.

  • 0

#4
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
I tried to search for several videos that gave me a URL on mouseover and went to page by clicking. None of them are in the Video database. Sends me to page that states: "No songs in our database matched

* Did you spell the words correctly?
* Try searching by bands
* Try searching by song title
* Try Browsing our Lyrics instead!"

This comes from http://search.lyrics...a...=13&I1.y=14

I never got sent to the Lyrics page directly. The <form> action does get me to this page: http://search.music..../launch/search/. But that was copied/pasted into address window. It then changes to: http://search.music.yahoo.com/search/ without "launch".

You do have 5 errors and 127 warnings for you coding on your page. Errors are critical and some refer to your <forms>. Possibly cleaning the code up will help.

Ron

Edited by Major Payne, 30 March 2007 - 07:35 PM.

  • 0

#5
stang

stang

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
The video search is suppose to link to Yahoo videos and for some reason the lyrics search bar is extending itself to all the search buttons even to my paypal button witch I had to remove because of this, all the field forms or correct also. I can create another cell and copy the video search bar there and it works fine, but I would have to redo everything. Is there any way to isolate these cells from each other? PS, I know about all the errors. I'm trying to get this fixed and finish up on some other stuff and I'll do a scan and a fix later. Thank you for helping me out.......stang
  • 0

#6
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
http://validator.w3....%...e&verbose=1

Very bad result. I think you will find that if you fixed all the errors your other problems would go away too. So delaying doing so will just make more work.

Did you use Word to make that page? I notice it has "urn:schemas-microsoft-com:office:office" in it.
  • 0

#7
stang

stang

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
I figured out a way to get it to work…. I created a small cell right on top of the video search bar and then copied the video search bar into the cell. Well the video search bar that I copied in the cell didn't work but the one I copied from under the cell started working. So I deleted the video search bar from the cell and left the one video search bar that I copied from under the cell, and it still works for some reason. The cell has the html form properties the bar needs to work. I doubt that this is the right way to do this but for now it works...Please inform me on where I can scan my site for errors. So I can start cleaning it up….Thanks again for your assistance, Stang
  • 0

#8
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Use that link in my previous post. That is the validator run by W3C (World Wide Web Consortium), they set the standards that every one is supposed to follow when writing HTML. The chairman for the consortium was the indenter of HTML.
  • 0

#9
stang

stang

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
I'm trying to clean up my site like you suggested, and every time I fix something it re-aligns some stuff on my site. I fixed the DOCTYPE html PUBLIC and now everything is spaced apart. I use FrontPage to edit my site because it’s easiest for me. Also after fixing the DOCTYPE html PUBLIC it looks OK on FrontPage but when I look at my site on the web its all spaced apart. I've tried to repair my site before and had the same results. That’s why I’m reluctant to fixing anything. Is there an easier way to do this without having to rearrange everything back like I had it?
  • 0

#10
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
Try useing something better than FrontPage, it will always create lots of errors. I recommend NVU http://www.nvu.com/index.php since it is good and free.
  • 0

#11
stang

stang

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Thank you for your suggestion. I can't tell you how many times I've tried to find something better than FrontPage to edit my site. I also use Dreamweaver but it takes a little getting use to. I installed Nvu and it works great I also set it up to edit striate from Internet Explorer. Thank You again.....Case closed........stang
  • 0

#12
Michael

Michael

    Retired Staff

  • Retired Staff
  • 1,869 posts
I would recommend you try to test the pages in something other than Internet Explorer.

The reason is that if you write pages in IE they tend to only work in IE, it follows the standards set by w3c very badly. So I use Firefox or Opera, then I know the pages should work in ever browser after a few little tweaks to bring IE back in line. Also Firefox be a better browser anyway.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP