Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

irritating ActiveX popup in IE


  • Please log in to reply

#1
cbesh2

cbesh2

    New Member

  • Member
  • Pip
  • 3 posts
I am working on a script that will be distributed on CD-Rom (it's my company's digital catalog). Since it includes a flash file, I get a popup bar in Internet Explorer that says, "To help protect your security, Internet Explorer has restricted this webpage from running scripts or ActiveX controls that could access your computer. Click here for options."

I have used the "mark of the web" (<!-- saved from url=(0012)http://localhost/ -->) to remove the popup, but now my hyperlinks that referernce the CD-Rom will not work. They can be clicked, but the links are never activated. Only the links to the web are activated. Is there a way to remove the popup while ensuring that all my links are working? I don't want my users to have to deal with this irritating notice every time they start up the CD.

Thanks for your help in advance.
  • 0

Advertisements


#2
stettybet0

stettybet0

    Trusted Tech

  • Technician
  • 2,579 posts
Flash files do not cause this warning to appear. It is probably due to an ActiveX control somewhere in your script. The popup bar is due to security settings in IE. If you use ActiveX, and the user has a security setting telling the popup bar to show (which is a default setting), then there's no way around it. Try not using ActiveX, there are many ways to do things that ActiveX does (without using ActiveX).

And by the way... your "mark of the web" is a comment... it comments out that code, so the browser doesn't read it. This is probably why the links don't work.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP