Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Radeon 1650Pro & Problems!

  • Please log in to reply




  • Member
  • PipPip
  • 20 posts
Rebuilt a PC for may son 10 months ago using a ASrock 939Dual-SATA2 and AMD 3000+. I reused Crucial 2 x512 DDR 2700 Ram and a Sapphire Radeon 9500 Pro AGP (128 Mb). Also put in new power supply (see next).

It ran ok for 8 months, then had to replace the power supply (faulty Antec SmartPower 2.0 400w) in January as it died, following random freezes. Replaced with an FSP Bluestorm 500W. Then seemed to run okay for next 2 months.

Early this month thought I would upgrade to a PCI-Express x 16 graphics and brought a Sapphire Radeon 1650 Pro (256 Mb). Brought on the basis that the 9500 Pro had been working okay for 4 years. Had a few problems getting it to run - failure to recognise the monitor and a couple of freezes. However, after getting all relevant Catalyst drver loaded it seemed ok.

The first week after the card in no apparent problems. However my son has in the last week had PC freezing on him after boot. Getting jagged orange lines when he get to windows log-on. If he gets through that without a hard reboot, then it seems to restart ok, but then a main desktop when trying to open an application everything freezes.

I spent 90 minutes on the phone (tonight) getting him to swap over the video-lead from each of the cards outputs so see what effect. Unistalled Catalyst drivers (7.3) , etc. which I had downloaded and regressed to Windows drivers. I got him to reinstall Catalyst drivers from the set up disk tha came with the card. Also seemed to hang even in Safe mode where we had to do the uninstall from (could not manage in Windows normally).

No BSODs just random freezes. Runs in internet explorer. Freezes in Word. Not tried any games in last week.

Views and help requested.

Is it a bad card? Overheating?
Is the card simply now showing up that the Motherboard damaged by the Antec psu that failed?

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP