Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Drive Letters Swapped


  • Please log in to reply

#1
BernieDoc

BernieDoc

    Member

  • Member
  • PipPip
  • 11 posts
I had a problem which is now fixed, but I don't know what caused it, or, to be honest, how it fixed itself.

A couple of days ago I could not get my system to boot. The fault was leading me to think that my hard drive (C:) had failed. I could, however, access DOS, and by doing so, I was surprised, when searching on C, and D, drives (I have 2 x 500Gig hard drives) to find that the drive letters had changed and that my C: drive, with windows, was now showing as D:, and vice versa.

I managed to fix my problem by going into BIOS and pointing the system to Windows on the, now, D: drive. The machine booted up and all was well.

Now, though, the system is showing Windows on the C: drive again and the order of my drives now appears back to normal.

Any thoughts on what happened to cause the initial problem? Has the system defaulted the system drive back to C: because windows is on it?

Just trying to understand what went wrong.
  • 0

Advertisements


#2
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
At the risk of confusing you even more, you need to be aware that if any of your C partition is NTFS (as opposed to FAT32) DOS cannot see it and so allocates it's drive letter to another drive. For example, I have two internal hard disks. One is NTFS (the Windows XP partition) while the other is FAT32. If I boot up with a DOS startup disk, there is no Windows XP partition and my second drive shows as drive "C". Drive "D" is then allocated to my DVD-writer.
This is all normal behaviour.

Edited by pip22, 30 April 2007 - 01:02 PM.

  • 0

#3
BernieDoc

BernieDoc

    Member

  • Topic Starter
  • Member
  • PipPip
  • 11 posts
Same problem again today. As I say, the solution is easy, I go into BIOS and point the boot option to the drive with Windows installed, which then has the effect of reassigning Drive C to the system drive.

I'd still like to know why my system appears to be randomly assigning different drives letters to the drives.

Any thoughts on what's causing it, or how I can stop it? I.E. can I permanently assign C: to my system drive so that it can't be changed?
  • 0

#4
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
Check the contents of the BOOT.INI file if it exists (a plain text file which can be opened (and, if required, edited) in Notepad. It could be pointing to the wrong drive as the one which contains the operating system. You can view the contents of this file by clicking on Start->Run and typing MSCONFIG. However, most single OS installations don't actually have this file (mine doesn't), in which case what you see in the MSCONFIG version is just a backup which isn't used. But it may be worth doing a search for it (with hidden and system files included in the search) just in case your system uses one.

Edited by pip22, 03 May 2007 - 01:54 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP