Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

system won't turn on

  • Please log in to reply




  • Member
  • PipPip
  • 12 posts
I originally had a problem with my system that struggle switching on. When I switch on the system, the fan would switch on for a second, then shut off. The only way I can get it to turn on is to wiggle the main power connector to motherboard.

My system finally shut down for good--I also a smelled of something burning. I felt the 500 PSU was probably struggling considering it is a SLI setup. So, I got a new 750 PSU and got a new motherboard. I put the system together, but the same problem happened--the fan would turn on for a second, then shut off. I decided not to try to turn it on of fear of wrecking another PSU.

So, whats the problem. Is it the case switch causing problem? Maybe its the HD, SLI, floppy? Any suggestions? I'm leaning towards case problem. Should I go ahead and get a case?
  • 0





  • Member
  • PipPipPip
  • 539 posts
so your running sli right? try only 1 card, eliminate the floppy,cd, and anything unneccesary for the system to run. try it once more and see if it works.

when you say you got a new system, what all is new, anything used from the last build? aka the cpu?
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP