Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Computer build problems


  • Please log in to reply

#1
Seven!

Seven!

    Member

  • Member
  • PipPipPip
  • 161 posts
After assembling the parts, my friend (who I can only communicate with via VoIP, I don't have the computer in front of me so pardon any delay in response), cannot get her computer to power up correctly. The only sign of power is the red HDD light, which is completely solid - regardless of whether the hard drive is connected or not!

I've gone through this: http://www.geekstogo...ems-t28727.html

And she's still having problems. Any help is appreciated.
  • 0

Advertisements


#2
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Do your fans turn on as well? If it is a new build and you have followed all of those steps then there is a chance that your MOBO was DOA.
  • 0

#3
Seven!

Seven!

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 161 posts
It was something hilariously stupid.... the power connector / reset switch and all that was matched by colour, not by function :whistling:.

Case closed :blink:.
  • 0

#4
Titan8990

Titan8990

    Member

  • Member
  • PipPipPipPipPip
  • 2,189 posts
Ahh, double check all connections should have made it that tutorial. Gald you got it worked out :whistling:.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP