Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows Update Troubles


  • Please log in to reply

#1
wadeb_21

wadeb_21

    Member

  • Member
  • PipPipPip
  • 387 posts
I'm having some trouble whenever I do a a windows update. Everytime I try to install the updates it fails every single time. I'm really not sure what is going on. I mean this computer has been sitting for along time so there is allot of updates that are required, but that shouldn't be the problem would it? If anyone knows anything I would really appreciate it, thanks in advance.
  • 0

Advertisements


#2
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
Can you get the error from event viewer or from windows update. It should give us an idea what is causing it. I know in windows update there is a section for failed updates that has more info.
  • 0

#3
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
Actually when I go to Update History it doesn't say that there is any failed updates. It just has Microsoft Windows Installer 3.1 and the status says it succeeded. However earlier today I removed that update and then tried to reinstall it because I thought that might have been the issue but then it wouldn't let me do that either would just keep failing when I would go through windows update. I finally went and just downloaded the Install 3.1 manually and it worked but now like I was saying nothing will update. It gets ready to install all the updates then an screen pops up that says the following updates were not installed and its every single update. Do you have any suggestions? Thanks
  • 0

#4
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
Did you check the event viewer for errors in the application or system logs?
  • 0

#5
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
I just checked it and I don't see any errors that say anything to do with windows update.
  • 0

#6
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
If you go to Add / Remove Programs, check the Show Updates box on the top. Does Windows Installer 3.1 show up as an installed update.
  • 0

#7
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
I just checked and yes Windows Installer 3.1 does show up.
  • 0

#8
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
I would reboot. Then go into Windows updates, choose one critical security update and try to install that, if that fails can you attach a screen shot so i can see whats going on.

Thanks
  • 0

#9
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
Alright I just rebooted then did the update and I'm still gettting the same thing I attached the screen shot. Hope this helps.

Attached Files


  • 0

#10
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
Instead of trying multiple updates at a time, only install one critical security update, and see if that fails.
  • 0

Advertisements


#11
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
Alright so I did one Security update at a time and then I did a critical update at a time I attached both screen shots. They both didn't work.

Attached Files


  • 0

#12
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
Windows creates a log when it installs updates. Do a search on your C drive for KB896423.log

If that doesnt work search for KB*.log

Post those up when you find them.
  • 0

#13
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
Alright I just did the search and this is what I found. It looks like a bunch of notepad files.
I attached a screenshot because when I tried to upload the notepad files it wouldn't allow me to. I also just took a random one and copy and pasted below what was in the notepad doc. Hope this helps.


[KB842773.log]
1.891: ================================================================================
1.891: 2007/07/09 09:45:02.578 (local)
1.891: C:\WINDOWS\SoftwareDistribution\Download\e9b0377463edd4b6480f6148a1f88bac\update\update.exe (version 5.4.15.0)
1.891: Failed To Enable SE_SHUTDOWN_PRIVILEGE
1.906: Service Pack started with following command line: -q -z -er /ParentInfo:ab2125a95d06e94f878447e24603a913
6.500: DoInstallation: CleanPFR failed: 0x2
6.547: SetAltOsLoaderPath: No section uses DirId 65701; done.
6.703: DoInstallation: FetchSourceURL for c:\windows\softwaredistribution\download\e9b0377463edd4b6480f6148a1f88bac\update\update_SP1QFE.inf failed
6.703: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB842773$
6.750: LoadFileQueues: SetupGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
6.953: BuildCabinetManifest: update.url absent
6.953: AnalyzePhaseZero used 0 ticks
6.953: No c:\windows\INF\updtblk.inf file.
7.000: AnalyzePhaseOne: used 47 ticks
7.000: AnalyzeComponents: Hotpatch analysis disabled; skipping.
7.000: AnalyzeComponents: Hotpatching is disabled.
7.000: Persisted hotfix directory is missing.
7.000: FindFirstFile c:\windows\$hf_mig$\*.*
7.000: Error getting find handle for c:\windows\$hf_mig$\*.*
7.031: AnalyzeForBranching used 31 ticks.
7.172: AnalyzePhaseTwo used 141 ticks
7.172: AnalyzePhaseThree used 0 ticks
7.172: AnalyzePhaseFive used 0 ticks
7.172: AnalyzePhaseSix used 0 ticks
7.172: AnalyzeComponents used 219 ticks
7.172: Downloading 0 files
7.172: bPatchMode = FALSE
7.172: Inventory complete: ReturnStatus=0, 469 ticks
7.172: Num Ticks for invent : 469
7.219: DoInstallation: ApplyAdminSystemAclsRecursive for c:\windows\$hf_mig$ failed; error=0x00000003
7.219: Allocation size of drive C: is 4096 bytes, free space = 26254041088 bytes
7.219: LoadFileQueues: SetupGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
7.438: Drive C: free 25037MB req: 9MB w/uninstall 11MB
7.438: Num Ticks for download : 266
7.438: CabinetBuild complete
7.438: Num Ticks for Cabinet build : 0
7.516: LoadFileQueues: SetupGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
7.703: Num Ticks for Backup : 265
9.688: Num Ticks for creating uninst inf : 1985
9.719: Registering Uninstall Program for -> KB842773, KB842773 , 0x0
9.735: LoadFileQueues: SetupGetSourceFileLocation for halaacpi.dll failed: 0xe0000102
12.922: System Restore Point set.
12.953: Copied file: C:\WINDOWS\System32\spmsg.dll
13.516: SfcTurnOff: System is not Win2k < SP2; Not turning off SFC.
13.516: SfcTurnOff: SFC was not turned off; using MakeSfcFileException.
13.516: In order to successfully complete this installation, the following services will automatically be stopped and re-started.
13.516: Background Intelligent Transfer Service.
17.797: VerifySize: Unable to obtain Target file size: C:\WINDOWS\System32\bits\qmgr.dll
18.125: AtomicReplaceFile: Calling HpReplaceSystemModule( C:\WINDOWS\System32\qmgr.dll, HFX24.tmp, _000045_.tmp, FALSE ).
18.125: AtomicReplaceFile: HpReplaceSystemModule failed; status=0xc0000003, location=684.
18.125: DoNoDelayReplace: Atomic replace support not implemented; disabling.
18.203: Copied file: C:\WINDOWS\System32\qmgr.dll
18.250: Copied file: C:\WINDOWS\System32\qmgrprxy.dll
18.422: Copied file: C:\WINDOWS\System32\DllCache\winhttp.dll
18.625: Copied file: C:\WINDOWS\System32\DllCache\qmgrprxy.dll
18.688: Copied file: C:\WINDOWS\System32\DllCache\qmgr.dll
19.094: Copied file: C:\WINDOWS\System32\bits\qmgr.dll
19.094: Copied file: C:\WINDOWS\System32\xpob2res.dll
19.235: Copied file: C:\WINDOWS\System32\winhttp.dll
19.641: Copied file (delayed): C:\WINDOWS\System32\SET2C.tmp
19.641: Copied file: C:\WINDOWS\System32\bitsprx3.dll
19.703: Copied file: C:\WINDOWS\System32\bitsprx2.dll
19.781: Copied file: C:\WINDOWS\System32\DllCache\bitsprx3.dll
19.844: Copied file: C:\WINDOWS\System32\DllCache\bitsprx2.dll
19.891: Num Ticks for Copying files : 10203
20.094: Num Ticks for Reg update and deleting 0 size files : 203
20.094: DoInstallation: ApplyAdminSystemAclsRecursive for c:\windows\$hf_mig$\KB842773 failed; error=0x00000003
20.094: Starting process: c:\windows\softwaredistribution\download\e9b0377463edd4b6480f6148a1f88bac\\SP1QFE\bitsinst.exe /setupservice /resourcedll:c:\windows\softwaredistribution\download\e9b0377463edd4b6480f6148a1f88bac\\SP1QFE\xpob2res.dll
24.360: Return Code = 0
24.360: Starting process: c:\windows\softwaredistribution\download\e9b0377463edd4b6480f6148a1f88bac\\SP1QFE\bitsinst.exe /setbackupfilter
27.547: Return Code = 0
27.547: UpdateSpUpdSvcInf: Source [ProcessesToRunAfterReboot] section is empty; nothing to do.
27.563: ---- Old Information In The Registry ------
27.563: Source:C:\WINDOWS\System32\_000045_.tmp (6.2.2600.1106)
27.563: Destination:
27.578: Source:C:\WINDOWS\System32\SET2C.tmp (5.1.2600.1557)
27.578: Destination:C:\WINDOWS\System32\winhttp.dll (5.0.1.0)
27.578: ---- New Information In The Registry ------
27.578: Source:C:\WINDOWS\System32\_000045_.tmp (6.2.2600.1106)
27.578: Destination:
27.578: Source:C:\WINDOWS\System32\SET2C.tmp (5.1.2600.1557)
27.578: Destination:C:\WINDOWS\System32\winhttp.dll (5.0.1.0)
48.266: IsRebootRequiredForFileQueue: At least one file operation was delayed; reboot is required.
If none are listed below, check above for delayed deletes.
48.266: IsRebootRequiredForFileQueue: c:\windows\system32\winhttp.dll was delayed; reboot is required.
48.266: IsRebootRequiredForFileQueue: c:\windows\system32\qmgr.dll was no-delay replaced; reboot is required.
48.266: DoInstallation: A reboot is required to complete the installation of one or more files.
48.281: RebootNecessary = 1,WizardInput = 1 , DontReboot = 1, ForceRestart = 0

Attached Files


  • 0

#14
jaxisland

jaxisland

    Member 1K

  • Member
  • PipPipPipPip
  • 1,703 posts
If you go back into Add / Remove programs and make sure show updates is selected to you see an entry for a windows update with KB842773?

The log you posted shows the update installed. They may be installing which Add/Remove should show but update is saying it failed.
  • 0

#15
wadeb_21

wadeb_21

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 387 posts
Alright I made sure the show updates was checked and none of the updates show in the add and remove programs list. Only the Windows Installer 3.1 showing, but none of hte KB updates are there. Do you know why it is doing that? I mean if it did update then why everytime I log on it says I have new updates ready and its all the same ones that your saying already have been update. I'm kind of confused.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP