Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Belkin Wireless G USB Network Adapter


  • Please log in to reply

#1
Oddysee

Oddysee

    Spammer

  • Banned
  • PipPip
  • 88 posts
So I installed the software for it using the disk. It then tells me I can now plug it in. Windows pops up saying it's identified "Belkin Wireless Adapter" but it wont install it. I set the directory for the software to the CD but windows still wont install it. Any help please?

I've googled this problem and found one guy who had the same problem but he never got it fixed :/.
  • 0

Advertisements


#2
acklan

acklan

    Retired Staff

  • Retired Staff
  • 442 posts
  • MVP
With the Belkin disk in the CD, have you tried to manually install the device from the "Add Hardware" Utility in the Control Panel?
I know you are suppose to install the hardware after the software, for USB devices, but obviously that is not working. Try installing the device from "Add Hardware" in the Control Panel.
  • 0

#3
J0N3Z

J0N3Z

    New Member

  • Member
  • Pip
  • 3 posts
hi
i suffered the same problem with the belkin g wireless usb adapter.
i am still unable to connect to the BThome hub for some unknown reason, any help is welcome.
maybe the problem lies with the product .
  • 0

#4
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts

hi
i suffered the same problem with the belkin g wireless usb adapter.
i am still unable to connect to the BThome hub for some unknown reason, any help is welcome.
maybe the problem lies with the product .

You really should start a new topic for this, as it is not the same issue.


Oddysee, Have you tried to reboot the machine and let Windows find the new hardware?
Some times it is best to download, and install, the drivers from the manufacture.
Are you still wired to the Internet?
  • 0

#5
J0N3Z

J0N3Z

    New Member

  • Member
  • Pip
  • 3 posts
yes i have rebooted several times and installed the drivers, however the homehub is still listed as not broadcasting by the software application. why is this??
  • 0

#6
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts

yes i have rebooted several times and installed the drivers, however the homehub is still listed as not broadcasting by the software application. why is this??

Please start your own topic.
I was replying to Oddysee.
  • 0

#7
J0N3Z

J0N3Z

    New Member

  • Member
  • Pip
  • 3 posts
Edit:removed offensive content
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP