Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Serious startup issues - safe mode broken too


  • Please log in to reply

#1
pj1115

pj1115

    Member

  • Member
  • PipPip
  • 23 posts
Hey

A trojan program installed itself on my PC and it's become 99% unusable since.

After the install, I constantly got pop-ups, and those 'You have been infected' messages. Naturally, I killed the processes, and deleted them from startup.

The first time I rebooted, and logged on (it worked fine up until then), I was greeted with a 'Generic Hosts Process has encountered an error and needs to close' message (I had been getting them for a few days). Then, explorer.exe starts but then seconds later it dies. Manually starting it has the same result. I managed to fix the generic hosts error by re-registering some libraries, but the explorer problem is not solved. Safe mode is no better because explorer doesn't work there either. I have to do everything from command line.

I tried replacing the explorer.exe with a fresh one from the install disk, but no luck.

Please, I need to get this sorted ASAP!

Edited by pj1115, 28 July 2007 - 04:07 PM.

  • 0

Advertisements


#2
Chopin

Chopin

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,639 posts
If you have malware, please go here for instructions on what to do :whistling:
  • 0

#3
pj1115

pj1115

    Member

  • Topic Starter
  • Member
  • PipPip
  • 23 posts
Well, I'll give it a try, but I'm not sure how I'll cope with no windows explorer, no sound, no safe mode and no decent system restore points...
  • 0

#4
Chopin

Chopin

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,639 posts
Trust me, these guys are good :whistling:
  • 0

#5
Chopin

Chopin

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,639 posts
Wait, did you say no Windows explorer? What do you mean by that?
  • 0

#6
Asukiy

Asukiy

    New Member

  • Member
  • Pip
  • 7 posts
Sorry wrong thread. :whistling:

Edited by Asukiy, 30 July 2007 - 03:08 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP