Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB Port Problem


  • Please log in to reply

#1
solsehjee

solsehjee

    New Member

  • Member
  • Pip
  • 3 posts
For most of my time with this laptop, an HP Pavilion dv5117cl, my Logitech wireless usb mouse has worked perfectly fine. One day it just stopped working. It said this when I'd stick the usb receiver stick into the usb port.

"USB Device Not Recognized
One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it..."

And when I click on the error message, I get a window showing this tree:

"USB Root Hub (4 Ports)
-Unused Port
-Unknown Device
-Unused Port
-Unused Port"

Anyway I've done a reinstallation of Windows, formatting the HD. I've also used PowerMAX to zerofill the HD. My question is do any of you recognize the problem and can you fix it? Or is it a hardware issue? If it's hardware, my warranty will cover it. I'm guessing it is because I did a zerofill, though I'm not sure because I'm not that knowledgeable. Please help. Thanks.
  • 0

Advertisements


#2
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
if you reinstalled windows after the zero fill then that should have nothing to do with it......have you reinstalled the drivers that came with the mouse?....have you tried multiple ports on the computer? other devices in the same port? does the mouse work on other computers
  • 0

#3
fleamailman

fleamailman

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,383 posts
one other, have you tried the device on another computer in case it is faulty
  • 0

#4
solsehjee

solsehjee

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
yeah i guess i didn't make it clear that the mouse is fine. it works on other computers. no usb device works on mine.
  • 0

#5
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
so absolutely NO usb devices work in ANY usb ports on y our computer? it's probably faulty ports
  • 0

#6
Hemal

Hemal

    Founding Fart

  • Technician
  • 1,470 posts
if you have usb drivers for the mobo or where ever your ports are located, then i would recommend re-installing those first to test to check if you just didnt have drivers loaded on...but if those dont work then it looks like your gonna need a new set of ports by either replacing your motherboard or what ever pci-card you are using
  • 0

#7
solsehjee

solsehjee

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
Alright thanks guys. I did make sure to reinstall drivers for the usb hub before all this. Since then it looks pretty clear it's a hardware issue i'll just send it in to Fry's.. their warranty covers all hardware issues. Thanks again really for the help.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP