Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

"Bios not acpi compliant" blue screen on laptop


  • Please log in to reply

#1
blabbaboo

blabbaboo

    Member

  • Member
  • PipPip
  • 20 posts
Hi, on a Presario m2000 I'm getting the message:

A problem has been detected and windows has been shut down to prevent damage to your computer.

If this is the first time youve seen this stop error screen, restart your computer. If this screen appears again, follow these steps:

The BIOS in this system is not fully ACPI compliant. Please contact your system vendor or visit http://www.hardware-update.com for an updated BIOS. If you are unable to obtain an updated BIOS or the latest BIOS supplied by your vendor is not ACPI compliant, you can turn off ACPI mode during text mode setup. To do this, simply press the F7 key when you are prompted to install storage drivers. The system will not notify you that the F7 key was pressed - it will silently disable the ACPI and allow you to continue your installation.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

This occurred after a power failure. Now it happens maybe 50% of the time, and the computer reboots. I've eliminated the hard drive and os as causes, flashed the bios to the newest available version, and the ram passes memtest with no errors. The only thing I can think of is replacing the ram, but I don't want to buy memory if it won't help the problem. Any suggestions? Thanks much!
  • 0

Advertisements


#2
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
If the ram passed memtest successfully then the problem, most probably, is not there. What tests did you perform to the hard disk? How did you exclude a possibility for a problem there?
  • 0

#3
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I actually replaced the hard drive with a known good drive and got the same error. Thanks for the reply!
  • 0

#4
123Runner

123Runner

    Member 4k

  • Member
  • PipPipPipPipPipPipPip
  • 4,305 posts
How many sticks of ram? Did you test each individually?
  • 0

#5
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
1 stick ram, 256mb, tried changing to other slot, too.
  • 0

#6
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Quote from post no.1: "If you are unable to obtain an updated BIOS or the latest BIOS supplied by your vendor is not ACPI compliant, you can turn off ACPI mode during text mode setup. To do this, simply press the F7 key when you are prompted to install storage drivers. The system will not notify you that the F7 key was pressed - it will silently disable the ACPI and allow you to continue your installation."

Have you tried this? To do this you have to start XP installation. When prompted to install drivers for SCSI devices press F7. Continue the installation up to the point where there are 3 options for repair or new installation. Cancel the installation at this stage and see if you still get the message.
  • 0

#7
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Yes I've tried this with the same result. It's driving me nuts! :whistling:
  • 0

#8
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
This problem interests me and I want to do some more research. I may take the advice of others from the technical staff. I understand your frustration.
  • 0

#9
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I appreciate your efforts on this. Thanks everyone!
  • 0

#10
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Howdy:

Boot into BIOS and disable the Power Management option.

Press F10 to save the change and exit.

See if that helps.

Murray
  • 0

Advertisements


#11
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
I bet that would work, but this bios has no power management option, even the new one I flashed it with.
  • 0

#12
Murray S.

Murray S.

    Trusted Tech

  • Member
  • PipPipPipPipPipPipPip
  • 4,513 posts
  • MVP
Did you check all the different locations within BIOS?

Murray
  • 0

#13
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Yes, power management is not there.
  • 0

#14
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Have a look at this link from microsoft, especially at the following quote:

"This principle also applies to systems that are not detected as ACPI-compliant. If the table header information is inaccurate, you can assume that the device configuration information that is contained in these tables is equally questionable. If you encounter any of the instabilities that are associated with overriding the default ACPI settings, Microsoft cannot assist you in any way short of a complete reinstallation of the operating system. An upgrade installation cannot fix the damage that is done by a bad or incomplete ACPI BIOS. However, if you must override these settings, use the following information."

I am afraid that a complete reinstallation of the operating system is required. However, before you do that (if you do) please try again the text stage in setup, this time pressing F5. I have seen places where they tell you to press F5.
  • 0

#15
blabbaboo

blabbaboo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 20 posts
Skeptic, your geniusosity is unparallelled! And you're smart, too. Hitting F5 during text setup stage did the trick! Many thanks to you and the others who responded to help me with this problem. Sorry I took so long to get back on here and close the thread, but with the after-repair party and all, I kind of lost track of the days. Kudos to you, sir, and again: Thank you all, drive safe, and have a pleasant tomorrow!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP