Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Cannot Install Internet Explorer 7


  • Please log in to reply

#1
eleasias

eleasias

    Member

  • Member
  • PipPip
  • 82 posts
I have tried several times to install Internet Explorer 7 to my computer, and It won't work. It looks as though the installation is working, but it reaches the "Finalizing installation..." and then says it did not install properly. It tells me to restart to remove any setup changes. I have tried Microsoft's suggestion to uncheck installing the updates and malicious software removal tool but it didn't work. What could be causing this? I have all other microsoft updates installed already, and can't figure out what i causing this. Thanks for any help folks. I appreciate your time.
  • 0

Advertisements


#2
imranxp

imranxp

    New Member

  • Member
  • Pip
  • 4 posts
Try installing it in safe mode.
  • 0

#3
Guest_MarkN_*

Guest_MarkN_*
  • Guest
Also try turing off all anti virus and protection software. If you are downloading it directly from Microsoft, I'm sure you are at a safe site.
  • 0

#4
eleasias

eleasias

    Member

  • Topic Starter
  • Member
  • PipPip
  • 82 posts
Yeah, I've turned off my anti-virus, with no results. I have tried installing it both through windows Update, and with the standalone executable downloaded from the Microsoft site.
  • 0

#5
Guest_MarkN_*

Guest_MarkN_*
  • Guest
I had the same problem about a month ago. But I can't remember how I fixed it. Let me think about it for awhile. What IE version are you using now?
  • 0

#6
eleasias

eleasias

    Member

  • Topic Starter
  • Member
  • PipPip
  • 82 posts
IE 6. I've also tried uninstalling IE 6 first, by going into Add/Remove Windows Components, but that didn't work either.
  • 0

#7
koko_crunch

koko_crunch

    Trusted Helper

  • Retired Staff
  • 1,751 posts
try starting xp without any startup items... then install..
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP