Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Flash


  • Please log in to reply

#1
paolo

paolo

    Member

  • Member
  • PipPip
  • 43 posts
I am having problems with Shockwave Flash files in Firefox. If I encounter a Flash file on a web page, I get the message:

You have chosen to open

foo.swf

which is a: Shockwave Flash Object
from http://xyz.com

What should Firefox do with this file?

* Open it with (currently I have firefox.exe selected, but that is wrong)
* Save to Disc

Do this automatically [etc]

Now, clearly I have my file associations messed up, but what should it be set to for swf files? Shouldn't Firefox just open Flash within the web page anyhow?

Thanks.
  • 0

Advertisements


#2
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
Do you have the plug-in for Firefox to play Flash? To check in FF, type in the address window about:plugins. It will give you a list of all Firefox plugins installed.

Ron
  • 0

#3
paolo

paolo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
Thanks. Yes, I do - I'd just updated to the most recent version as well (although I have had this problem for some time). Here's what's listed for Flash:

Shockwave Flash

File name: NPSWF32.dll
Shockwave Flash 9.0 r47

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Adobe Flash movie swf Yes
application/futuresplash FutureSplash movie spl Yes


Any ideas why it still isn't working even when the plug-in is there?

PS: I'm using Firefox 2.0.0.6 on Windows XP with service pack 2.

Edited by paolo, 12 August 2007 - 10:54 AM.

  • 0

#4
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
In FF, check Tools, then select Options. On the Content tab click the "Manage..." button listed under File Types. make sure that SWF and SPL are listed to open with the Shockwave Flash. Also, what is the exact link to SWF you are trying to view. As long as I don't have to log in or sign up for the site, I'll see if it views in my FF.

Ron
  • 0

#5
paolo

paolo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts
SPL is listed to open with Shockwave flash. SWF is absent. I see you can modify existing file types, but is there anyway of adding a new one?

The site is http://carbon.cudenv.../g4/index2.html

Thanks for your help.
  • 0

#6
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts
I had no trouble viewing the Flash at the link you gave.

If you are getting no SWF file type listed in FF where I asked you to look, then you may not have the Firefox plug-in installed properly even though about:plugins reported that you have it. Will have to check as to whether it can be added to the Manage... window in FF, but if plugin was there to use, it should be listed. You could check the Plugin folder for Firefox to see if it's there.

Ron

P.S. You're not using anything like AdBlock or FlashBlock are you?

The Adobe Flash Player Plugin is the one you need. Might try to re-install in from the link provided.

Edited by Major Payne, 13 August 2007 - 04:19 PM.

  • 0

#7
paolo

paolo

    Member

  • Topic Starter
  • Member
  • PipPip
  • 43 posts

I had no trouble viewing the Flash at the link you gave.

If you are getting no SWF file type listed in FF where I asked you to look, then you may not have the Firefox plug-in installed properly even though about:plugins reported that you have it. Will have to check as to whether it can be added to the Manage... window in FF, but if plugin was there to use, it should be listed. You could check the Plugin folder for Firefox to see if it's there.

Ron

P.S. You're not using anything like AdBlock or FlashBlock are you?

The Adobe Flash Player Plugin is the one you need. Might try to re-install in from the link provided.


OK, I installed the plug-in from the link you gave and it makes no difference:

* about:plugins still says that I have application/x-shockwave-flash (Adobe Flash movie, swf) and that it is enabled
* SWF is still not listed in Manage...
* I still get the dialog asking me what I want to do with an swf file when I go to a site that uses Flash
* I still have the file association of SWF files to Firefox

How can I disable the last of these? Isn't it the case that once you've got an association of a file extension with an application, it always has to be associated to some application or other?

Thanks.
  • 0

#8
Major Payne

Major Payne

    Retired Staff

  • Retired Staff
  • 5,307 posts

I still have the file association of SWF files to Firefox

How can I disable the last of these? Isn't it the case that once you've got an association of a file extension with an application, it always has to be associated to some application or other?

Need to set the SWF association to the FF plugin and see if that does it.

You should always be able to change the association to a file type in Folder Options/File Types tab. Whether it asks you what program to associate a particular file type depends on whether you checked the box to always associate that program with that file type.

Ron
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP