Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

2nd HD


  • Please log in to reply

#1
trucker

trucker

    Member

  • Member
  • PipPipPip
  • 227 posts
I"M not sure if i put this in the right place so move it if you need to.
here's what Ive got.
2 HD 3 OS.
the problem I'm having is with the grub. and on the 2ND HD.

hda has winxp hdb has ubuntu and vector. when i install vector it made the remainder for that drive unuseable . why, this is a 120 gig dr ive used around 10 gigs. would the way i formatted the drive matter?
i ran dban to blank the dr then put in a 512mb dos formatted it. when i run partition editor i see 120 gig dr. but when i open window computer dr D its 512mb.
as for the grub error 15 pops up no stage 1. i have a working grub i made on a floppy with super grub but i dont see how to put it HD.
thanks for any help :whistling:
  • 0

Advertisements


#2
silverbeard

silverbeard

    Trusted Tech

  • Member
  • PipPipPip
  • 791 posts
hi trucker,

You have to make sure that the "/boot/grub/menu.list" file has the entries needed to mount the OSes installed on your system. SimplyMepis has one of the best GRUB installers I've found. It detects Operating systems better than any other I've tried. I still usually have to manually Edit my menu.list file because I usually us custom kernels on my systems.

Here is the GRUB page. Here is the GNU GRUB Manual.

This is one of my menu.list files on my older system:

timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1

gfxmenu /boot/grub/message



title MEPIS at hdb1, kernel 2.6.15-26-386
root (hd1,0)
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hdb1 nomce quiet vga=791
boot

title Windows at hda2
rootnoverify (hd0,1)
chainloader +1

title MEMTEST
kernel /boot/memtest86+.bin

Note that the linux distro is on hdb(hd1,0) and windows is on hda2(hd0,1). You mainly have to point GRUB to the right boot Partition for the os your loading.
  • 0

#3
trucker

trucker

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 227 posts
thanks! wish i would have came here sooner. the grub was so messed up i had to start over and redo 2nd drive. i went with ubuntu this time not kubuntu. i know it a bit better. still a newbie with linux.
but i still dont understand whats going on with this. i can not make partitions shouldnt i be able to make as many as i want to? i made linux swap then a 3000mb pri 83 . that work ok but if i make a sec 3000mb linux 83 pri, it makes the rest of my hard driver unuseable. is this right.
frist thing i did was to make a 512 dos i booted to win xp pro and fomatted it then setup ubuntu. it works just great now even got all my files from window on ubuntu desktop thats a frist for me.

but then i went to put in vector soho and got an error during setup. so i aborted.

my reason for vector is: i have 3 old panasonic toughbooks 2 are pen r 233 . 1 is pen2 all have 160mb ram and 20 gig HD. i'm trying to get them setup for simple web stuff. all three have to use pcmcia cards or usb adp to get to the web. ive trid xubuntu but it really sluglish so far vector seems to work about the best from what ive found. i just dont understand linux very well so i figured if i got it on this pc i could play with it.
if you know of a better way to go im open, the main thing im looking for is to stay away from alot of line command, ive heard of ububntulite but i couldnt get that disk to even boot.

right now win xp and ubuntu are setup on this pc and working just great thanks for any help on this
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP