Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

usb trouble


  • Please log in to reply

#1
thejackenator

thejackenator

    New Member

  • Member
  • Pip
  • 3 posts
hey i got a sandisk cruzor and off-brand external hard drive. i don't know if it happened when i plugged the cruzor in or before that but they both don't work now. also, after turning my computer on, with nothing plugged in, it thinks there is a usb drive plugged in. although nothing is plugged in the safely remove hardware icon is in the bottom right and i can 'safely remove usb mass storage device - Drive (F:)'. i've tried uninstalling a bunch of stuff in device manager and in hkey local and can't get that one thing to stay gone or the others to work. it will recognize and assign letters to the cruzor and external ard drive but if i click properties it says they have 0 of o bytes.

i had all my music on the external hard drive.

CAN SOMEONE PLEASE HELP
  • 0

Advertisements


#2
thejackenator

thejackenator

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
OK i think the usb mass storage device that says is plugged in and i can't get rid of has something to do with my printer. it is a new hp photosmart c4200. i think that is the root of my problems. when i plug the cruzor in it says it is installed and ready to use and then says one of the usb devices attached to this computer has malfunctioned and windows does not recognize it. it doesn't get assigned a drive letter. is is listed in safely remove hardware thing as Unknown Device.
  • 0

#3
thejackenator

thejackenator

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
well it will now run my new external hard drive and printer fine! they are both plugged in the back. but if i try to plug my cruzor into one of the front usb hubs it doesn't work. does anyone know what i can do to fix this
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP