Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

New Build Problems


  • Please log in to reply

#1
Snippy

Snippy

    Member

  • Member
  • PipPipPip
  • 211 posts
Hello,

I just recently bought a new Mobo, Graphics Card, Case, CPU Fan, and a new PSU.
I put it all together and what not and then I connect in the PSU cable and turn the
switch to "on" on the PSU and nothing happens. BUT I hear a little faint beep inside
the computer but not from the speakers. I reconnected everything and checked
the connection to the ram , CPU Fan, PSU cables, and everything! Still no results
any help would be greatly appreciated!


Snippy



Oh and to add something. The beep is really really faint. It's like a high pitched beep.
I think the PSU is completly dead 'cause when I hook it up and switch it on the fans
in the PSU don't even turn on.

Edited by Snippy, 20 August 2007 - 07:18 PM.

  • 0

Advertisements


#2
Snippy

Snippy

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 211 posts
OK I have tested out my PSU and it does work. But I've noticed on the
24pin connector that there is 1 missing slot that does not have a connector
slot in it. See pic.

Posted Image


Could this be the cause of my problems?

Posted Image
  • 0

#3
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Hi there

You've got an Antec PSU, right? If so, then the missing pin is perfectly normal. Also it's normal for the rear fan to not come on straight away.
The single beep you can hear is probably also normal - most system will emit one beep from the system (internal) speaker following a successful POST test.
When you power the system on, does the cpu fan spin? Does the LED on your monitor turn from amber to green?
  • 0

#4
Snippy

Snippy

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 211 posts
Nah the PSU is a Rosewill. And no absolutely nothing happens. I called up the MoBo Maker
And they said it is a problem related to the motherboard has a short to the memory cards
so im taking it back for a replacement and when I get the new one in and installed I'll
post here if it works or same problem.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP