Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Bioshock Demo Problem


  • Please log in to reply

#1
Dreylivude

Dreylivude

    Member

  • Member
  • PipPipPip
  • 109 posts
This is weird. I'm trying to play the new Bioshock demo and I can't see my mouse pointer, but I can still click on things with a bit of luck. When I finally find my way to starting the game, the graphics go rather insane, lots of back and a few objects showing up in places. I uninstalled, and downloaded another copy from Gamespot (First one was from fileplanet) and still have the same problem.

I also found the ATI hotfix that was released for this game, which said it includes my card, and still no worky.

I used Syspec to get my specs, which are listed below.

I heard rumours that this game used Pixel Shader 3.0, which my card does not support. If that's true, why would ATI release a hotfix for the game which works for my card?

Any ideas?


Windows: Windows XP5.1 (Build 2600) Service Pack 2
Internet Explorer: 6.0.2900.2180
Memory (RAM): 2048 MB
CPU: Intel® Core™2 CPU 6320 @ 1.86GHz
CPU Speed: 1846.6 MHz
Sound card: SoundMAX HD Audio
Display Adapters: RADEON X800 Series | RADEON X800 Series -Secondary | NetMeeting driver | RDPDD Chained DD
Screen Resolution: 1152 X 864 - 32 bit
:
Network Adapters: Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC - Packet Scheduler Miniport
CD / DVD Drives: D: HL-DT-STDVDRAM GSA-4163B
:
COM Ports: COM1
LPT Ports: LPT1
Mouse: 3 Button Wheel Mouse Present
Hard Disks: C: 30.0GB | E: 44.5GB | F: 95.4GB | G: 184.0GB
Hard Disks - Free: C: 18.7GB | E: 26.8GB | F: 78.9GB | G: 117.7GB
USB Controllers: 7 host controllers.
Firewire (1394): Not Detected
:
Manufacturer: American Megatrends Inc.
Product Make: System Product Name
:
AC Power Status: OnLine
BIOS Info: ATAT COMPATIBLE 102606 A M I 10000626
Time Zone: Atlantic Standard Time
Battery: No Battery
Motherboard: ASUSTeK Computer INC. P5B
Modem: Not detected
  • 0

Advertisements


#2
MoNsTeReNeRgY22

MoNsTeReNeRgY22

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,539 posts
Hello Dreylivude,

Visit the following site and select BioShock - PC from the pull down menu.

http://www.canyourunit.com/

Then select Can you RUN It?

Let it download anything it needs to.

Post back on the results please.
  • 0

#3
-=PR=-MadMax

-=PR=-MadMax

    New Member

  • Member
  • Pip
  • 1 posts
Same problem as i had. Try this hotfix from ATI: http://support.ati.c...uestionID=29041

Its a 97Mb download and should fix this problem with the display being all screwed up :whistling:



737-29041: BioShock: Users may experience stuttering with Preload, Missing surfaces and/or display corruption.


The information in this article applies to the following configuration(s):
BioShock
Catalyst Display Driver
Radeon™ HD2900 series
Radeon™ HD2600 series
Radeon™ HD2400 series
Radeon™ X1950 series
Radeon™ X1900 series
Radeon™ X1800 series
Radeon™ X1650 series
Radeon™ X1600 series
Radeon™ X1550 series
Radeon™ X1300 series
Radeon™ X1050 series
Radeon™ X850 series
Radeon™ X800 series
Radeon™ X700 series
Radeon™ X600 series
Radeon™ X550 series
Radeon™ X300 series
Radeon™ 9800 series
Radeon™ 9700 series
Radeon™ 9650 series
Radeon™ 9600 series
Radeon™ 9550 series
Radeon™ 9500 series
Windows Vista 32-bit Edition
Windows Vista 64-bit Edition
Windows XP Professional
Windows XP Home Edition
Windows XP Media Center Edition
Windows XP Professional x64 Edition
Symptoms:
Users may experience stuttering with Preload, Missing/black surfaces and/or display corruption.


Solution:
Please download and install the following hotfix file to address this issue.

Windows Vista Hotfix

Windows XP Hotfix


Edited by -=PR=-MadMax, 22 August 2007 - 10:57 AM.

  • 0

#4
starjax

starjax

    Global Moderator

  • Global Moderator
  • 6,591 posts
when you install the game, it automatically checks our video driver version and sends you to the appropriate website if you need newer drivers. Thought that was pretty cool.
  • 0

#5
dantrojan

dantrojan

    New Member

  • Member
  • Pip
  • 1 posts
Hi all

I am having the same problem.

I have installed the ATI hotfix. and the canyourunit.com website says i pass everything.;

I still get the funny graphice once i finally get into the game.. i'm stuck in the water and everything is black and some funny plates of graphic come and go, i can see flames though 0_0

Please assist me if you know what i can do.

XP Pro.

intel p4 2.8
ATI 9600XT sapphire 256mb
2GB RAM.



Thanks
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP