Jump to content

Welcome to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message and all ads will be removed once you have signed in.
Create an Account Login to Account

Windows Vista Restarts Automatically When it is Shutdown


  • Please log in to reply

#1
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
Hello,
I recently bought a new laptop (Toshiba Satellite) that runs Windows Vista Home Premium. I haven't had any issues, until I installed a series of Windows Updates on 8/16/2007. Now my computer restarts automatically everytime I choose "shutdown" from the start menu. The only way I can successfully turn it off is by manually holding the power button on the computer until it turns off.

I've tried doing a system restore to before the problem started, but it hasn't helped.


I'd appreciate any suggestions for a fix! Thanks. :whistling:

Edited by spacefroid, 25 August 2007 - 10:27 PM.

  • 0

Advertisement


#2
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
Anyone? :whistling:
  • 0

#3
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
The Windows Start Menu's new shut down default is "sleep" - however, you may want to change this for whatever reason. To change it:

1. Click on Start, and then click on Control Panel.
2. Click on "System and Maintenance".
3. Click on "Power Options".
4. Select a power management plan and then click on "Change Plan Settings".
5. Click on "Change advanced power settings".
6. In the Power Options dialog that appears, expand "Power Buttons and Lid", and then expand "Start menu power button".
7. Click on "Setting" and then choose the function you want the button to perform - "Sleep", "Hibernate", or "Shut down".
8. Click on OK.

source: Helpero http://www.helpero.c...ista_10365.html
  • 0

#4
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
Thanks for the suggestion, but I've already set that to "shutdown". Also, the problem isn't that I'm pressing the start menu button and it's not turning off. Even when I specifically choose "shut down" the computer will shut down, but restart all by itself after a couple of seconds.

Any other ideas?
  • 0

#5
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
In case anyone else has this problem, and comes across this topic - I found a solution! In my case, my BIOS needed to be updated to the most recent version, which solved the problem.

Hope this helps!
  • 0

#6
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
Excellent! Thanks for letting us know how you resolved your problem. :whistling:

I've mentioned that so many times on other forums, and I'm met with: "but, it's a brand new computer, I'm sure the BIOS is updated".
  • 0

#7
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
Sigh.
So it turns out, I was wrong. The BIOS update only made it shutdown right once, and then it continued to restart after I shut it down, as before. It shuts down normally when on battery power, but once the AC adapter is plugged in, it restarts. So, I'm still looking for a solution.

Hopefully someone will be able to help; if not I'll get back when I have a real solution.

Edited by spacefroid, 19 September 2007 - 08:55 AM.

  • 0

#8
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
Even when you close the lid?
  • 0

#9
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
.. Even when I close the lid.
  • 0

#10
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
When you click on "shut down" button, does windows then say logging off and then another screen appears and says Windows is shutting down?
  • 0
<

Advertisement


#11
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
Yup, there's the "logging off.." and "shutting down" and then it shuts off. It's just the 5 seconds later that it'll turn itself back on.
  • 0

#12
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
Hmmm, something is allowing itself to reconnect. Do you have 'automatic updates' turned on for all your programs?
  • 0

#13
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
Go to Power Options..on the left, click on 'choose what the power buttons do'.
What are your settings for battery and plugged in?
  • 0

#14
spacefroid

spacefroid

    Member

  • Member
  • PipPip
  • 24 posts
For "When I press the power button," on battery it's set to sleep, and plugged in is set to "shut down".

For "When I close the lid" on battery it's set to sleep, and plugged in is set to "do nothing"

I do have automatic updates turned on for everything, which is when I started getting this problem - after an automatic windows update.
  • 0

#15
Jacee

Jacee

    Malware Expert

  • Expert
  • 992 posts
  • MVP
Okay, change those settings to "shut down". and click 'save'.

Now when you 'shut down your computer, are you clicking on the button that looks like shut down (an 'O' with a small vertical line on the middle/top of it ) or are you clicking on the arrow with a choice of options?

Click on the arrow and choose 'shut down'. Your computer should not restart on it's own again.
  • 0

Advertisement



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured