Jump to content

Welcome Guest to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Feel free to browse the site as a guest. However, you must log in to reply to existing topics or start a new topic of your own, and enjoy all this forum has to offer. Additionally, if you can assist another member by sharing your knowledge, please post a reply! Best of all - Registration and all assistance, is FREE! Learn more about How it Works. Infected? Malware Cleaning Guide. What are you waiting for?
Create an Account Login to Account

Word 2007 - Continuous Macro Errors


  • Please log in to reply

#1
Nibinaear

Nibinaear

    New Member

  • Member
  • Pip
  • 3 posts
I've just upgraded to Office 2007 and I'm having serious trouble using Work 2007. Every time I load the program, even if I only load a blank document I get up to 7 continuous Macro errors; It's really anoying. I've tried doing as the advice says but, whether the macros are turned on or off makes no difference, I still get warnings, even though I've aparently turned them off. Here is the error:


MICROSOFT OFFICE WORD

The function you are attempting to run contains macros or other content that requires macro language support. When this software was installed, you or your administrator chose not to install support for macros or controls.

This error usually occurs because of macro security settings. If you know that the macro comes from a source that you trust, you can change your macro security settings to allow you to enable the macro. The way that you change your macro security settings depends on the Microsoft Office System program that you are using.
Microsoft Office Access, Microsoft Office Excel, Microsoft Office PowerPoint, or Microsoft Office Word --

To check your macro security settings, click the Microsoft Office Button, click <program name> Options, click Trust Center, and then click Trust Center Settings.
If macro security is set to Disable all macros without notification, all macros are automatically disabled. Use the following procedure to enable the macro.
In the Trust Center dialog box, click Macro Settings, and then click Disable all macros with notification.
Click OK in the Trust Center dialog box to apply the new setting. Click OK to close the program options dialog box.
Close the file and the Microsoft Office program that you are using.
Open the file again. A Security Alert appears in the Document Information Bar just below the ribbon. Click Enable Content to allow the macro to run.
When you have enabled the macro, it is recommended that you return the macro security setting to Disable all macros without notification.
If macro security is set to Disable all macros with notification, but you selected Disable when prompted by the macro warning dialog when you opened the file, use the following procedure to enable the macro.
In the Trust Center dialog box, click Cancel. Click Cancel to close the program options dialog box.
Close the file and the Microsoft Office program that you are using.
Open the file again. A Security Alert appears in the Document Information Bar just below the ribbon. Click Enable Content to allow the macro to run.
If macro security is set to Disable all macros except digitally signed macros, the macro may not have been digitally signed. Verify that you can trust the macro before using the following procedure to allow it to run.
In the Trust Center dialog box, click Cancel. Click Cancel to close the program options dialog box.
Close the file and the Microsoft Office program that you are using.
Open the file again. A Security Alert appears in the Document Information Bar just below the ribbon. Click Enable Content to allow the macro to run.

Microsoft Office Outlook, Microsoft Office Visio, or Microsoft Office Publisher --

To check your macro security settings, on the Tools menu, click Trust Center, and then click Macro Security.
If macro security is set to No warnings and disable all macros, all macros are automatically disabled. Use the following procedure to enable the macro.
In the Trust Center dialog box, click Warnings for signed macros; all unsigned macros are disabled, and then click OK.
Close the file and the Microsoft Office program that you are using.
Open the file again. When prompted, click Enable Content to allow the macro to run. If you are using Visio, the Enable Content button appears as part of a Security Alert in the Document Information Bar. If you are not prompted to enable the macro, or if you receive this error again, the macro may not be digitally signed. Verify that you can trust the macro. If you are certain that you can trust the macro, use the next procedure below to enable the macro.
When you have enabled the macro, it is recommended that you return the macro security setting to No warnings and disable all macros.
If macro security is set to Warnings for signed macros; all unsigned macros are disabled, the macro may not be digitally signed. If you are certain that you can trust the macro, use the following procedure to enable the macro.
In the Trust Center dialog box, click Warnings for all macros, and then click OK.
Close the file and the Microsoft Office program that you are using.
Open the file again. When prompted, click Enable Content to allow the macro to run. If you are using Visio, the Enable Content button appears as part of a Security Alert in the Document Information Bar.
When you have enabled the macro, it is recommended that you return the macro security setting to Warnings for signed macros; all unsigned macros are disabled.

Microsoft Office Project --

To check your macro security settings, on the Tools menu, click Macro, and then click Security.
If macro security is set to Very High, use the following procedure to enable the macro.
In the Security dialog box, click High, and then click OK.
Close the file and Microsoft Office Project.
Open the file again. When prompted, click Enable Content to allow the macro to run. If you are not prompted to enable the macro, or if you receive this error message again, the macro may not be digitally signed. Verify that you can trust the macro. If you are certain that you can trust the macro, use the next procedure below to enable the macro.
When you have enabled the macro, it is recommended that you return the macro security setting to Very High.
If the macro security setting is set to High, the macro may not be digitally signed. If you are certain that you can trust the macro, use the following procedure to enable the macro.
In the Security dialog box, click Medium, and then click OK.
Close the file and Microsoft Office Project.
Open the file again. When prompted, click Enable Content to allow the macro to run.
When you have enabled the macro, it is recommended that you return the macro security setting to High.

This error may also occur for the following reasons:
The certificate of trust that is attached to the macro is invalid. Unless you are certain that the macro is safe, it is recommended that you not trust or run the macro.
The certificate is no longer trusted, was revoked by the issuing authority, or is damaged. Unless you are certain that the macro is safe, it is recommended that you not trust or run the macro.
Visual Basic for Applications (VBA) is not installed on your computer. In this case, no VBA macro can be run, regardless of whether the macro has a valid certificate of trust. You or your administrator may have chosen not to install VBA, or the version of Microsoft Office that you are using may not install VBA by default. If your version of Microsoft Office does not provide VBA as an installable feature, you can upgrade to a version that provides VBA support.
If you are unable to change the security settings, it is possible that another program has locked the security settings. Close all Microsoft Office System programs, then restart your program and change the security settings.
More information about this error message online.



One thing I don't understand is the area I've highlighted in bold. What are they on about? I load the file again but I just get the same warnings, what is a ribbon? What is the document information bar?

PS: I've searched Google but found no help whatsoever.

Edited by Nibinaear, 24 August 2007 - 07:47 AM.

  • 0

#2
jgeorgeff

jgeorgeff

    New Member

  • Member
  • Pip
  • 1 posts
Same issue here. Running Vista. Any updates are appreciated. THanks.
  • 0

#3
nachotech

nachotech

    New Member

  • Member
  • Pip
  • 1 posts
Fixed!

I had this problem and resolved it by disabling the .COM add-in for ScanSoft PDF Professional 4. As soon as I disabled that plug-in, and restarted Word or Excel, the macro warnings disappeared.

I hope this works for someone else with this problem.

Iggy
(my blog)
  • 0

#4
EBeast

EBeast

    New Member

  • Member
  • Pip
  • 1 posts
Ha, after spending hours messing around with macro settings, I found this. Removed an Adobe PDF COM add-in, restarted Word2007, problem fixed.

btw, that add-in is completely un-necessary, since microsoft has a 'save as PDF or XPS' add on that can be downloaded free.

Glad I found this thread though, these warnings were really getting annoying! :) :) :)
  • 0

#5
Mad Loaf

Mad Loaf

    New Member

  • Member
  • Pip
  • 1 posts
I've experienced this macro error with several versions of Word and several versions of Windows. I've just uninstalled Office Live and the problem has disappeared on one computer. Can't wait to try this solution on the other computers. I'm certain it will work.
  • 0

#6
Annix

Annix

    New Member

  • Member
  • Pip
  • 1 posts

I've experienced this macro error with several versions of Word and several versions of Windows. I've just uninstalled Office Live and the problem has disappeared on one computer. Can't wait to try this solution on the other computers. I'm certain it will work.


That did the trick. Removing that Office Live plugin. No more errors with Macro's.
YAY! :)
  • 0

#7
silverskull

silverskull

    New Member

  • Member
  • Pip
  • 2 posts
I removed Office Live Plugin and had no success.

I went back to Add/Remove Programs and Microsoft Office 2007.
Select Change and Add/Remove Features.
Expand Office Shared Features and the arrow beside Visual Basic for Applications. Click Installed on First Use.
Click Continue and let it work itself.

Open Microsoft Word and it will do something install-y, then you're set.

:)
  • 0

#8
silverskull

silverskull

    New Member

  • Member
  • Pip
  • 2 posts
Sorry, double post! :)

Edited by silverskull, 23 October 2009 - 05:23 PM.

  • 0

#9
spadgos

spadgos

    Banned for BugMeNot sharing

  • Banned
  • Pip
  • 2 posts

I removed Office Live Plugin and had no success.

I went back to Add/Remove Programs and Microsoft Office 2007.
Select Change and Add/Remove Features.
Expand Office Shared Features and the arrow beside Visual Basic for Applications. Click Installed on First Use.
Click Continue and let it work itself.

Open Microsoft Word and it will do something install-y, then you're set.

:)


Thank you, this was the solution for me
  • 0

#10
alexpk321

alexpk321

    New Member

  • Member
  • Pip
  • 1 posts

I removed Office Live Plugin and had no success.

I went back to Add/Remove Programs and Microsoft Office 2007.
Select Change and Add/Remove Features.
Expand Office Shared Features and the arrow beside Visual Basic for Applications. Click Installed on First Use.
Click Continue and let it work itself.

Open Microsoft Word and it will do something install-y, then you're set.

:)



That worked for me too! Thanks dude, that was driving me nuts!!
  • 0

#11
Ardemus

Ardemus

    New Member

  • Member
  • Pip
  • 1 posts
Thanks folks. I had the same issue. I also found a new COM add-in in Word. Removing it solved my problem. I did not install or enable VBA macros since I'm not using them and they are a common malware vector.

The add-ins are found in the Word Options dialog off of the file menu (circular button in the upper left). This is how I got rid of it:

  • Launch Word as an Admin
  • Go back to the Add-ins page
  • Select "COM" next to manage and click go.
  • From there I could disable or remove the add-in

In my case the COM add-in was "Send to Bluetooth". It must have been installed by Broadcom's, or IOGear's blue tooth drivers (I had just troubleshot my USB dongle).

Nick

Edited by Ardemus, 07 October 2010 - 08:25 PM.

  • 0

#12
ahmad_345

ahmad_345

    New Member

  • Member
  • Pip
  • 1 posts
THNX ALOT .... It Really Helped ...... It Was Annoying Warning ........ Thnx Again !!!

:D

This thnx goes for Silverskull

Edited by ahmad_345, 19 March 2011 - 11:21 PM.

  • 0

#13
twisted_tx

twisted_tx

    New Member

  • Member
  • Pip
  • 1 posts
I am just as amazed as anyone else, but installing Visual Basic for Applications resolved the issue. The only thing I can figure out is that some of the addins make use of some of the libraries/APIs offered by this component.
  • 0

#14
Bluhead

Bluhead

    New Member

  • Member
  • Pip
  • 1 posts
Brilliant, yes this is it more or less. My copy of Word went spazzz yesterday with the Macro message, after reading the posts above I had a look at the addins, none of those mentioned were active, but there was a com addinin to send information to bluetooth. Disabled it(could not remove it as it want an administrator to remove it, even though I am the only user and administrator) and everything works nicely again. Interesting thing is I am not aware of having specified that I wanted to add options ot send stuff to bluetooth. (Yeah I do run firewalls etc). So there you have it.
  • 0

#15
boogie_down2991

boogie_down2991

    New Member

  • Member
  • Pip
  • 3 posts
This is happening to a guy in my office. He's running a windows 7 OS, but I am not certain where to begin looking for these add-ins. His word wont even open... no matter how many times you click okay, it doesn't go away. Any advice to fix this?
  • 0



Similar Topics: Word 2007 - Continuous Macro Errors     x


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured