Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Add New Hardware Wizard Refuses to "See" Drivers!


  • Please log in to reply

#1
Draiden

Draiden

    New Member

  • Member
  • Pip
  • 1 posts
Hey all, I'm new here, and asking this on behalf of a desperate friend who has no internet access due to a very strange series of events...

1) My friend purchased a new webcam off of eBay. The webcam is not a no-name, but from a reputable brand, and seems innocent of any relation to the following problems. Link Here to eBay Item.

2) When they received this webcam, they successfully installed its drivers and commenced using it with a program called "Eyeball Chat". Link Here to EyeBall Chat.

3) In their very first video-chat session, when they quit the Eyeball Chat program, their internet abruptly failed. They lost net connectivity through every one of their other internet-related programs: browsers, AIM, etc.

4) After numerous (failed) attempts to restore connectivity, they formatted their computer. The old and new OS were both Windows 2000. No service packs have been installed since the format.

5) Their laptop is a Gateway Solo 2550. It uses a device to adapt its modem port to connect to an Ethernet cable. The cable is fine. They have another computer, which is also fine, and still has internet access. Both computers receive access via the same router. This is the device: Linksys Etherfast USB100M Network Adapter

6) Since formatting, they have repeatedly tried to reinstall the drivers for this device. The drivers are also located at the page above. It is a self-extracting executable file that contains a .CAT file, a .SYS file, and an .INF file.

7) They have also tried installing the drivers via the command line, with the RUNDLL32 etc. setupapi.dll,installhinf etc... line. That failed. Then, they tried forcing the computer to ignore unsigned drivers, and repeating that. That still failed. They even tried using Microsoft Driver Tools ((Link Here.), but that required a service pack they had no access to.

8) They (and myself) had given up hope, when, by a mixture of luck, perserverance, and coincidence, they decided to decouple ONLY the ethernet cable from the adapter, RATHER than pull the entire combination of the ethernet cable+adapter from the USB port. THEN, they simply plugged the ethernet cable back into the adapter. And -something- happened:

9) A completely DIFFERENT wizard/dialogue appeared upon plugging the ethernet cable back in- this one was unlike the Add New Hardware Wizard in that it new specifically the device that was being detected, and asked, specifically, for the INF file in question. When she satisfied its location-queries, she found that Internet Access had (miraculously?) been restored.

Originally, this post was going to stop at stage 8, and I was going to hope someone else here on the forums would supply the steps to successfully resolve this situation. Happily, that is no longer needed; but, if anyone cares to share it, I would still like any knowledge or just information on why, perhaps, this happened in the first place, what the root cause might have been, and how it might be prevented in the future.

In short- why does the "Add New Hardware Wizard" sometimes not see the INF file you're asking it to use, even when you're pointing directly at the folder (or even file, by typing it into the specify location bar) it's supposed to use? And how can that be fixed? And if it can't, how can that be circumvented? If one has only a combination of .cat/.sys/.dll/.inf files (a driver archive, for example), how can one manually install those without using the ANHW? Please let us know. Thank you all very much.

Edited by Draiden, 07 September 2007 - 08:54 PM.

  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP