Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Windows XP 32-bit and x64 dual boot


  • Please log in to reply

#1
hockey2112

hockey2112

    New Member

  • Member
  • Pip
  • 7 posts
Hello all,

I have a PC with Windows XP Pro 32-bit installed, and I recently installed Windows XP Professional x64 on a separate partition. The installation went fine, and I booted directly into XP x64 upon completion of the installation. However, when I rebooted the computer again, it does not give me the option to boot into x64.

I know it has something to do with my boot.ini file, but I am not sure how to fix the problem. Here is the main issue…

My XP 32-bit is installed on drive C, which is one of two partitions on my main SATA hard drive, the other partition being drive D.

My XP x64 OS is installed on a partition of my drive E, which is an IDE HDD. The partition for x64 is named drive Q.


The x64 installation placed the x64 boot.ini file on drive F, and this is how it reads:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(3)\WINDOWS="Windows XP Professional x64 Edition" /noexecute=optin /fastdetect



The original boot.ini for my 32-bit XP is of course residing on drive C. This is how it reads:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /usepmtimer



I have tried all sorts of changes to my C-drive’s boot.ini, but none of them will enable me to boot into x64. This does not surprise me, as I am totally new to the whole dual-boot thing. Can anyone here point me in the right direction as to how I can make this work? I would rather not do a new install of x64, but will do it is it is necessary to do so.

Thanks!
  • 0

Advertisements


#2
hockey2112

hockey2112

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
New development... I was able to get msconfig to accept x64's path as bootable by changing it to this...

multi(0)disk(0)rdisk(2)partition(3)\WINDOWS="Windows XP Professional x64 Edition" /noexecute=optin /fastdetec

However, when I selected x64 to boot up, it gave me the following error message (before the windows logo ever showed up or anything:

Windows could not start because the following file is missing or corrupt:
<Windows root>\system32\ntoskrnl.exe .
Please reinstall a copy of the above file.


I checked on the C drive's Windows folder as well as that folder on the Q partition, and the file exists in both places, albeit at different file sizes (the one on C - 32-bit - is 2.03 MB, and the one on Q - x64 - is 4.21 MB).

What to do now? Do I need to copy the x64 version of the file to the C-drive's system32 folder, replacing the existing one there, do I need to copy it again from my x64 install disk? Any ideas?

Thanks!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP