Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

nv4_disp problems- Please help!

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 8 posts
Whenever I play Battlefield 2142, after anywhere from 1-30 minutes it freezes, stays like that for a bit, and then gives me a blue screen with the nv4_disp error. (image attached) Strangely, this only seems to happen in Titan mode, but either way, I've been trying to fix this for a while now. It seems like I've tried nearly every fix available, short of RMAing my card. I have turned off antialiasing, updated my graphics card drivers, updated my BIOS, updated the game, turned off write combining, used Driver Cleaner Pro to clean off the drivers and reinstall them, reverted to older drivers that I've heard have worked (they were release 90 drivers, but they didn't help, so I went back to release 162), checked DxDiag, checked the Error Log, etc. Please, if someone knows a way to fix this, please help! Listed below are my specs from SysSpec.
[codebox]Dell XPS 410
Windows: Windows XP5.1 (Build 2600) Service Pack 2
Internet Explorer: 7.0.5730.11
Memory (RAM): 1022 MB
CPU: Intel® Core™2 CPU 6400 @ 2.13GHz
CPU Speed: 2103.9 MHz
Sound card: SigmaTel Audio
Display Adapters: NVIDIA GeForce 7300 LE | NetMeeting driver | RDPDD Chained DD
Screen Resolution: 1280 X 1024 - 32 bit
Network Adapters: Intel® 82566DC Gigabit Network Connection - Packet Scheduler Miniport
CD / DVD Drives: D: TSSTcorpDVD+-RW TS-H553A
COM Ports: COM3
LPT Ports:
Mouse: 3 Button Wheel Mouse Present
Hard Disks: C: 228.1GB
Hard Disks - Free: C: 196.9GB
USB Controllers: 7 host controllers.
Firewire (1394): Not Detected
Manufacturer: Dell Inc.
Product Make: Dell DXP061
AC Power Status: OnLine
Time Zone: Eastern Standard Time
Battery: No Battery
Motherboard: Dell Inc. 0WG855
Modem: Conexant D850 56K V.9x DFVc Modem
I've also tried to run a 3DMark06 test, but that didn't go so well. I clicked Run and the tests were moving around 1-2 FPS. Not sure if that's right, because BF2142 is not that slow. I've searched the forum, but nothing really helped and some of the posts were kinda old. I'm just wondering if anyone has found a fix yet.

  • 0




    Global Moderator

  • Global Moderator
  • 6,585 posts
well the 7300 isn't the best card for this kind of game. However, that doesn't help your problem. Looking through what you have done I'm leading toward 2 things.

1)a deep operating system problem which can only be resolved by a complete reload of your system. Rather drastic measure to take.

2)hardware problem. I am personally leaning toward this. Try and do an rma.

Edited by starjax, 12 September 2007 - 12:14 PM.

  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP