Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Motherboard, Monitor/ALL USB Ports Don't work when powered on. on


  • Please log in to reply

#1
dizzle23

dizzle23

    New Member

  • Member
  • Pip
  • 1 posts
The CPU Was fine, but slow, so i tried to install another 512mb DDR. I've done it before, but did not want to damage it as it was hard to press in place..,. SO, i plugged all cables back in place. only 1 was left: the end of the hard drive pwr Supply(the smallest one, #31,h705,) But i don't recall taking it off. i just replaced Power supply and motherboard; so please let me know what you guys think it could be. the new M.B. MODEL= P4M80-M4. I would greatly appreciate anyone that can help; thanks
  • 0

Advertisements


#2
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Hi dizzle23, welcome to Geeks to Go!

Unfortunately, it seems your title runs into the content of the thread and I'm a bit confused about the actual problem. Are you able to describe the problem a bit more clearly? Please also include: Components in your system (make/model), and steps you've tried to fix what's happening.

Cheers, :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP