Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Mouse Wont Work


  • Please log in to reply

#1
stasfickit

stasfickit

    Member

  • Member
  • PipPip
  • 24 posts
Hi Everyone!!

Here's the problem. My old mouse was dieing on me for the last month or so. ( it would work then all of a sudden stop working and i'd have to smack it to start working again ) So i got a new one. Problem is that the new one doesn't work. Supposedly you just plug it in but all it does it light up. So i asked the people at the geek squad about it. They said that i needed to download some plug and play thing because that's probably the reason it doesn't work. I don't even know where to start. Any suggestions?
oh and years ago i did get some hardware work done (i don't even remember what they did) if that helps. Thanks!!

"i hate using the keyboard mouse thing it's soo annoying!"
  • 0

Advertisements


#2
Adrenalin

Adrenalin

    Member

  • Member
  • PipPipPip
  • 451 posts
i see you using windows xp, it should automatically install your mouse, unless you have plugged it into the front ports of your case and havent plugged the cables in on your motherboard, thats the only reason i can think of.

try plug it into another usb port [i am assuming you using a usb mouse?]
  • 0

#3
shard92

shard92

    Member 1K

  • Member
  • PipPipPipPip
  • 1,129 posts
have you tried it in safe mode? You get to safe mode by tapping the f8 key on boot up and selecting safe mode from the screen. If it does work in safe mode then the next thing to try is to open device manager ( right click my computer, choose properties, and select hardware then device manager.... Once there look for and remove any listing for mouse and then reboot.... it should redetect your mouse.
  • 0

#4
stasfickit

stasfickit

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Yes, i do use a usb mouse. I've tried plugging it into all of my 6 usb ports and i even have the add on in which u can plug it into the mouse port and it gets power every single time but i dont get any reaction. ( no message saying new hardware has been found or anything)

I haven't tried using it in safe mode yet. Hopefully what shard92 says works.
  • 0

#5
stasfickit

stasfickit

    Member

  • Topic Starter
  • Member
  • PipPip
  • 24 posts
Mouse Doesn't Work In safe Mode. :)
  • 0

#6
Adrenalin

Adrenalin

    Member

  • Member
  • PipPipPip
  • 451 posts
I'm assuming here that you have tried another mouse? Also that your USB drivers are installed and set correctly in the BIOS?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP