Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Does Windows network really slow?


  • Please log in to reply

#1
narquam

narquam

    New Member

  • Member
  • Pip
  • 2 posts
I'm a computer expert but I've been struggling with finding a solution to this for months. My network is really slow. It's a gigabit network and sometimes it can take hours to transfer a gig worth of data, depending on my traffic. You might wonder why I didn't put this under network. I believe this is a Windows problem and not something wrong with my network.

I have Windows XP (can't stand Vista) on two PCs and a laptop. They are all fast machines and all up to date. They have no malware, viruses, or adware. I'm 100% sure of this. Two of these systems have Gigabit LAN cards all using static IPs. My router is a D-Link DIR 655. It's a gigabit draft N router. First off, draft N does not run any faster than G. At least not with any of my XP systems. I set up two systems and my network to give me an accurate speed of transfer. The fastest speed reported was 10mbps. Now this is a transfer through a full gigabit network with no other traffic. I get better transfer through firewire and USB2.0.

Now I've tried all kinds of fixes I've seen over the Internet. This makes me quite angry. My network is so high speed and there is no reason for it being this slow. I even tried connecting two systems through a 100mb switch. I still only had around 10mbps transfer speed. If anyone knows anything to fix this problem I would be so happy. I feel like running a network via firewire around my house. I don't have any other OS to test with so I can't be sure, but it's really annoying when trying to stream HD video from one system to another or move large files.
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Tried new cables? Windows Networking is generally no slower than other types of networking but usually a lot depends not just on traffic but on the condition of the systems being transferred to/from (such as the software they're running, the specifications, whether they're doing other things (Disk Defragmenter under XP runs automatically after an extended state of sitting idle, for example), state of their hardware, etc).
  • 0

#3
narquam

narquam

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Good news for me I have found the problem. I started trying different cables and even completely opening up my router and cutting all connections to the Internet and other PCs. I eliminated all running services and programs and still I only got 10mbps. I ended up finally thinking about the driver settings for my network card. I tried switching everything. I have an onboard nForce 4 gigabit Ethernet. I found that one of the driver's settings is "optimize for" and its options are cpu or throughput. Changing it to throughput on both systems changed everything. I also changed the setting for "Checksum Offload" to enabled. By default checksum offload is set to disabled and optimize for is set to cpu. These settings kill the network. I now copy a 1Gb video file in less than one minute. It has also majorly upped browsing the network and my Internet speed. All of the lag is gone.

I looked up some info on Checksum Offload and found it is by default, set by windows, disabled. If you want more info on what it is, check the link below. So anyone looking for an answer to a slow network and you can't figure out why, especially if you have an onboard nforce ethernet, change your driver settings. Especially try these two.

http://www.microsoft...askoffload.mspx
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP