Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

MMC Cannot open (device manager)


  • Please log in to reply

#1
xdbguard

xdbguard

    New Member

  • Member
  • Pip
  • 3 posts
I was following this thread

http://www.geekstogo...ile-t97798.html

and applied the final fix the poster claimed worked to fix his problem. It did not fix mine so I began at the beginning and when I got to this post:

Ok

start > run
mmc
<enter>

In the empty console,

FILE > ADD/REMOVE SNAP-INS

click ADD

Select DEVICE MANAGER

ADD button, FINISH button, CLOSE button, then OK button

In the console, you should see Device Manager

FILE > SAVE AS, click the DESKTOP button on the left and save it as devmgmt.msc

Now close the mmc

on your desktop, double click devmgmt.msc

Does it open? Device manager?

MY ANSWER IS YES, it opens the device manager. Now what do I do to be able to open the device manager though the system information? I have already applied the registry fix found here:http://www.kellys-korner-xp.com/regs_edits/devicemanagerrestore.reg and it did not work.

xdbguard
-Windows XP

Thanks
  • 0

Advertisements


#2
anzenketh

anzenketh

    BSOD Warrior/Computer Surgeon

  • Technician
  • 2,854 posts
Hello xdbguard.

Welcome to geekstogo. Thank you for taking the time to search for a possible solution for your thread. Did you do the other steps suggested in the thread or just jump down to what seamed complected and thought was the fix? This is a rare issue so posting the results is very important. In addition if you decide not to work with us on this issue please say so. This will help for better documentation of issues and solutions.

What happens if you do start > run > cmd > eventvwr.msc ?
or start > run > cmd > services.msc ?

Edited by tuxmaster, 04 November 2007 - 02:48 AM.

  • 0

#3
ViprXX

ViprXX

    Member

  • Member
  • PipPipPip
  • 172 posts
so device manager will only open if you double click the devmgmt.msc file on your desktop and not any of the other usual ways such as Right-click My Computer, click Properties, click the Hardware tab, and then click Device Manager. if so then try copying the devmgmt.msc file you created on the desktop and paste it into C:/WINDOWS/System32
then try accessing it via the above mentioned way or another way is to Click Start, click Run, and then type "devmgmt.msc" (without the quotation marks).

good luck
  • 0

#4
xdbguard

xdbguard

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

Hello xdbguard.

Did you do the other steps suggested in the thread or just jump down to what seamed complected and thought was the fix?
What happens if you do start > run > cmd > eventvwr.msc ?
or start > run > cmd > services.msc ?



As mentioned in 1st post, I read the thread, found the posters final solution and applied it. It did not work in my situation, so I began at the top and tried everything I read, up until the post I copied here about "snapping in" or some such thing. I stopped there because I got a desired result- the device manager opened from the file on the desktop. (devmgmt.msc) And I posted a question about what I should do next. I did not continue applying/trying anything until I received an answer here.

When I start>run>cmd>services.msc the services window and eventviewer windows open.

I have done sfc /scannow twice with no results.


"if you can't open anything ending in msc try this
http://www.dougknox....c/xp_mscfix.zip
didn't apply to me because I can open files in msc (services)

if you can open those...but just not devmanager
try this
http://www.kellys-korner-xp.com/regs_edits...estore.reg'
I applied this, it says it added it to the registry, but did not fix the problem

"Please right click this LINK, choose SAVE LINK AS or SAVE TARGET AS, and save it somewhere on your computer where you will remember where it is located. Then find the file on your computer and double-click it to run it. Click YES to the warning: Are you sure you want to add the information in FILE LOCATION HERE\msi.reg to the registry? Then reboot your computer and once rebooted see if you can go to START-->RUN and type services.msc and have the Services windows appear." did not work

"Lets check and see if the files are actually there. Browser to C:\WINDOWS\SYSTEM32 folder and see if you can locate the devmgmt.msc or services.msc file. Make sure you are able to view hidden files/folders when doing this and that operating system files are not hidden."
The files are there

"start > run
mmc C:\Windows\System32\devmgmt.msc
<enter>"
file does not open

"if you type s
start > run
mmc
<enter>

does a blank mmc open?"
YES

And then we arrive at what I originally posted in my inquiry:
Ok

start > run
mmc
<enter>

In the empty console,

FILE > ADD/REMOVE SNAP-INS

click ADD

Select DEVICE MANAGER

ADD button, FINISH button, CLOSE button, then OK button

In the console, you should see Device Manager

FILE > SAVE AS, click the DESKTOP button on the left and save it as devmgmt.msc

Now close the mmc

on your desktop, double click devmgmt.msc

Does it open? Device manager?

YES

And then I stopped and reported the desireable result and asked how to get the file to open the proper way- thru my computer properties.

Thanks

Edited by xdbguard, 04 November 2007 - 07:43 AM.

  • 0

#5
xdbguard

xdbguard

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts

so device manager will only open if you double click the devmgmt.msc file on your desktop and not any of the other usual ways such as Right-click My Computer, click Properties, click the Hardware tab, and then click Device Manager. CORRECT

if so then try copying the devmgmt.msc file you created on the desktop and paste it into C:/WINDOWS/System32
then try accessing it via the above mentioned way or another way is to Click Start, click Run, and then type "devmgmt.msc" (without the quotation marks).

good luck



ok I will try this. I am away from my desktop for the next 18 days. But will be checking the boards on the road. Thank you.

Edited by xdbguard, 04 November 2007 - 07:42 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP