Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problems/Upgrade Video Card


  • Please log in to reply

#1
strikermed

strikermed

    Member

  • Member
  • PipPipPip
  • 214 posts
Hey guys,

I am currently having problems with my video card, ATI Saphire X800 GTO 256. It began with playing BF2, and I noticed a few times on other games, like the Age of Empires demo, and COD4 demo. I thought at first it was one of the games, but as I kept going through the games I found it might be a driver problem, so I rolled back drivers, adn that still didn't do the job. I got to the point where I went back as far as I could with drivers, and went through windows updates to install the current driver. So far it has slight problems still.

I think what is happening is it is tearing in game?.?.? I see random lines that shouldn't be there, and glitches all over teh screen. I don't know how else to explain it. I am currently waiting for an external hard drive to be delivered, and I'm going to transfer all my files to it, and try to reinstall windows to get a fresh start. I usually do that every 6 months to a year to keep my computer running smoothly, and to clean out the junk.

If you have any suggestions on fixing the problem, or ideas on what is wrong I would appreciate it.

Also, if that doesn't fix the problem I would like to get a new graphics card in the 200 dollar or below range. I'm interested in ATI and Saphire products, I"m not really fond of Geforce... If you have any ideas, let me know, Like I said, my card is x800 GTO, kinda old these days.

OH, I almost forgot, I also wanted to attempt to overclock my video card, and see if that might be a problem. Might be a problem that these games can't run on this card or something....

Okay, thanks all!
  • 0

Advertisements


#2
james_8970

james_8970

    Trusted Tech

  • Retired Staff
  • 5,084 posts
What you appear to be witnessing based on your description, is artifacts.
Don't overclock the card in it's current state.
There are a number of things that could be causing this, try droping the settings to low.
Double check that the fan is still running as the card may be over heating.
What catalysts version do you have your card running on?
James

Edited by james_8970, 06 November 2007 - 01:42 PM.

  • 0

#3
strikermed

strikermed

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 214 posts
I have the current version of teh catalyst software, and I have all the current drivers, I tried roling back that didnt' work, i retired installing the original software that came with the card, and that didnt work.

Is this happening because my card isn't good enough anymore? I did reduce all the settings to low, and it reduced the effects, and in certain occasions it fixed it, for a while, I never really stressed tested the situation. Why does this happen? Is there something wrong with my card?
  • 0

#4
james_8970

james_8970

    Trusted Tech

  • Retired Staff
  • 5,084 posts
The card is older, but should just manage to get buy with these games, if it is unable to play them it should crash to a black screen, not create artifacts.
Do you know the temperature of the card under load? If you don't know how to do this just let me know.
James
  • 0

#5
strikermed

strikermed

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 214 posts
I have fan running at 100%, VPU Clock running at 398.25, board temp is around 58, VPU temp is around 85 to 100, memory clock is at 492.75.
These are all on standard setting.


I also have been receiving messages saying VPU Crash, it resets the VPU I believe, and asks me to send an error report... (it's not one of those window's warning it's an ATI one)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP