Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Youtube


  • Please log in to reply

#1
NField

NField

    Member

  • Member
  • PipPip
  • 61 posts
Hi, im having issues with youtube, it takes ages for most videos to load up even though i have just updated my computer with 1.5gb ram and a new PSU. it never used to be bad before. thanks alot for any advice.
  • 0

Advertisements


#2
unizo

unizo

    Member

  • Member
  • PipPip
  • 11 posts
Your best bet will be ringing up your Internet Service Provider and asking them about it, problems like that are normally internet related and aren't down to your hardware.
  • 0

#3
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
This is down to lack of Internet bandwidth. The new PSU and memory has no influence on the physical speed of your internet. Contact your provider
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP