Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Shutdown -i


  • Please log in to reply

#1
matt.

matt.

    Member

  • Member
  • PipPip
  • 80 posts
Hey, im currently running a network of computers about 10 or so.

I'm trying to use this command threw CMD

Shutdown -i
Then adding computer's to shutdown list and shutting them down instead of walking around doing it manually...

I get a message in CMD saying Access is denied
Failed: *Computer Names*

How come it's giving me this fail message? and how can i fix this.

Thanks Alot.
  • 0

Advertisements


#2
pip22

pip22

    Trusted Tech

  • Banned
  • PipPipPipPipPip
  • 2,663 posts
remote shutdown from a command prompt requires the following syntax: shutdown -m \\computername
  • 0

#3
matt.

matt.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 80 posts
Ok, i tried. but then it goes straight into the menu

i typed shutdown -m \\computername
and it came up with the menu of commands
eg
-i (explains what this does)
-s (explains what this does)
-d (explains what this does)

the exact menu of shutdown -help

it doesnt do anything :S...
  • 0

#4
Ax238

Ax238

    Tech Staff

  • Technician
  • 1,323 posts
That's because you are still missing something. Try the following command (replacing computername with the name of the computer):
shutdown -s -m \\computername

Regards,

Ax
  • 0

#5
matt.

matt.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 80 posts
i get the following message when typing in your command
threw command Prompt.

"Acess is denied."
  • 0

#6
Ax238

Ax238

    Tech Staff

  • Technician
  • 1,323 posts
Make sure you are running from an admin account on the network.

Edited by Ax238, 18 November 2007 - 12:43 AM.

  • 0

#7
matt.

matt.

    Member

  • Topic Starter
  • Member
  • PipPip
  • 80 posts
i am running from an administrative account, i changed all the account's on the computers to non and rechecked 2 make sure and they are fine...

do i need to make my own netword instead of MSHOME?! or that wouldnt matter?
  • 0

#8
Ax238

Ax238

    Tech Staff

  • Technician
  • 1,323 posts
You could try the following command:
runas /netonly /user:yourdoman\youruser "shutdown -s -m \\computername"

The runas command allows you to specify a different user to execute a program that the current user wouldn't have access to. In this case using the /netonly switch targets the remote computer for the authentication.

After executing the above it will ask you for a password for the remote user and it keeps the password hidden from anyone watching.

You can type runas ? in the command line to see more information for the command.

Also just found this from experts-exchange.com:

In order to remotely shut down a machine, you must be an administrator on the machine you are currently logged on to, as well as an administrator on the remote machine. Even with this condition met, however, remote shutdown may still be disabled in Group Policy (either local, or domain policy). Check the following on the remote machine (or its domain controller if one is present):

* Start->RUN | MMC
* On the topmost menubar, File->Add/Remove Snapin
* Click Add
* Select Group Policy, then click add
* Click Finish, the Close, Then OK
* Click the (+) next to "Local Computer Policy"
* Navigate to the following key:

Local Computer Policy->Computer Configuration->Windows Settings->Security Settings->Local Policies->User Rights Assignment

* Check who is allowed to "Force shutdown from remote system"

The access denied message will appear either because your username/password doesn't exist, you dont have administrator account status on BOTH machines, or Adminsitrators do not have that Right on the remote machine.

You can also get to the Group Policy console by entering gpedit.msc in the command line.

Regards,

Ax
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP