Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Installer service fail to start


  • Please log in to reply

#1
trodas

trodas

    Member

  • Member
  • PipPipPip
  • 101 posts
Windows 2000 SP 4 here. After some tweakings and problems (including removal od some spyware and stuff) my Installer service can't be started. Hence, for example, installing anything is not possible. And, for example, FF can't use the M$ java, so...

Anyone know, what to do, beside reinstall, to make it working again?

The C:\WINNT\system32\msiexec.exe /V file is here. The service is not disabled, it is on manual. However when in services I choose to start it, then in fail to and report that "service did not return any error", so it might be a Windows itself fault :)

[bleep]. Anyone having some ideas, what to test?
  • 0

Advertisements


#2
trodas

trodas

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 101 posts
I got only 6 disabled services. I set them all back to manual yet no help. Prior to that, I tried unregistering and reregistering msiexec:
msiexec /unreg
msiexec /regserver
Sadly no help either. So I tried installing the updated installer ( http://www.microsoft....displaylang=en ), sadly no help either. Then I tried the unreg/reg trick again, just to be sure and it's still not helping...

So I fired up FileMon to watch what is going on when I try start the Installer service and the results are only 3 problems:

313 11:46:36 msiexec.exe:776 OPEN C:\WINNT\system32\msiexec.exe.Local NOT FOUND Options: Open Access: All

336 11:46:36 msiexec.exe:776 OPEN C:\WINNT\system32\Program\picture.exe PATH NOT FOUND Options: Open Access: All

363 11:46:36 msiexec.exe:776 QUERY SECURITY C:\WINNT\Installer INVALID DEVICE REQUEST

INVALID DEVICE REQUEST?! :)

I tried take a look at the Dial-a-fix utility and I must say it helped me with my other problem - my windows positions are NO remembered before. It found out that there was set some nasty limitations (probably by spyware), witch caused these settings are NOT remembered.
Well, not anymore. Dial-a-fix helped me greatly! http://wiki.djlizard...tandard_version

Sadly it did not help me with the installer problem... :)
  • 0

#3
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Go to Kelly's Korner on this link. Run item no. 94 on the left side of the menu.
  • 0

#4
trodas

trodas

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 101 posts
I better ask, the item on the left side, or on the right side in the line 94..?

The line goes: "94. Windows Installer Fix - Winnt for Windows"

...and frankly I'm not entierly sure if I should try the first smaller wininstaller.reg, or the later bigger wininstallerwindows.reg registers stuff.

PS. fingers crossed that this will work. ATM I trying solution no. 4 from there: http://support.micro...kb;en-us;324516 :)
  • 0

#5
trodas

trodas

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 101 posts
Well, no answer... so I used both of these register files, first the one smaller, on the left. Reboot. No change :) Then the right, bigger one and also no change. Any ideas now? :)
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP