Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Memory speed problem


  • Please log in to reply

#1
DarkGuard

DarkGuard

    New Member

  • Member
  • Pip
  • 9 posts
Hey there, i am new in the forum and thats my first topic. I really need help with that because i cant find a way to solve that problem. So here is my PC for starters:
AMD64x2 Dual Core 5800+
Gigabyte GA-M57SLI-S4 Ver:2 - BIOS version FE
Gigabyte Nvidia GeForce 7600GT 256MB
Kingston KHX6400D2/1G HyperX x2 - total 2G Ram at 800Mhz
Power supply: 550W
And thats my problem: When i first installed the PC (first time i opened it) at boot screen at BIOS i saw that my computer identified my Ram at 667Mhz speed. I read that my motherboard supports 800Mhz DDR2 Rams but my Rams where identified at 667 speed. Then i searched about the voltage needed for my Ram to work properly and about how many volts my motherboard's DDR2 slots give, and i get that numbers: My Rams need 2v to work at full speed(800Mhz) and my motherboard's DDR2 slots give only 1.8v. I also saw that KHX6400D2/1G HyperX work at 667Mhz speed if the voltage of the motherboard is 1.8v. I tried to overvoltage the DDR2 slots to 2v but my Rams still working at 667Mhz. Is there any other option i need to change from my BIOS so i can achieve 800Mhz speed? Thanks in advance.
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Welcome to G2G

Have you tried going into the bios & setting the DDR2 Voltage Control (in M.I.T section) to +0.2V?
  • 0

#3
Troy

Troy

    Tech Staff

  • Technician
  • 8,839 posts
Hi DarkGuard, to answer your PM - no I haven't actually had this problem myself.

I've just been researching your motherboard on the Gigabyte website - there are three versions for it. Yours is version 2.0, and the BIOS version FE is the latest. So we're all good to go there.

Seeing as you have increased the voltage to 2.0V (by setting it to +0.2V), try this:
As soon as you enter the BIOS, press down <ctrl> and <F1> buttons, your screen should flash like it was refreshing itself. Then enter the M.I.T. section and see if anything is available to be changed that wasn't before.

Or did you try this already?
  • 0

#4
DarkGuard

DarkGuard

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Hey there. Thanks for the replies. I just came home from work and tried ctrl+f1. BIOS refreshed and Advanced Chipset Features appeared. Checked there and found some more setting for my memory(DRAM Configuration). I changed my memory speed to 800Mhz and saved it, but now i need to check if the timings are right. The menu in the DRAM Configuration is like this one:

Cas# Latency : 5t
1T/2T Command Timing : 1T
TwTr Command Delay : 3T
Trfc0 for DIMM1 : 105ns
Trfc0 for DIMM2 : 75ns
Trfc0 for DIMM3 : 75ns
Trfc0 for DIMM4 : 75ns
Write recovery time : 5T
Precharge Time : 2T
Row Cycle Time : 21T
Ras to Cas R/W delay : 5T
Ras to Ras delay : 3T
Row precharge time : 5T
Minimum Ras active time : 15T

All that command are disabled(at auto configuration). My Ram timings are 5-5-5-15 at 2.0V. Because i don't know what that T means or the Row, Ras, Cas or anything else, maybe you know if i need to change any of that so my Ram works at properly speed?
  • 0

#5
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Hi there

Your ram is designed by default (i.e using Serial Presence Detect chip SPD) to run at 667MHz 1.8V, which is also the JEDEC standard. However, this particular memory has also been tested at 800MHz 2.0V. This explains why the system defaults to 677MHz 1.8V.

The timings given by Kingston for either voltage, are 5-5-5-15 (CL-tRCD-tRP-tRAS)

CL (CAS Latency) is 5t
tRCD (Ras to Cas) is 5t
tRP (Row Precharge time) is 5t
tRAS (min RAS active time) is 15t

So in short, the timings are fine.
  • 0

#6
DarkGuard

DarkGuard

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Thanks allot. And something last... Do i need better cooling for my pc? I now that AMD possessors need better cooling than Intel. And know with the overvoltage maybe i need something more?
  • 0

#7
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Whether you need to improve the cooling is dependent on the sort of temperatures your system is currently running at.

I believe that your motherboard comes with Easytune 5 which will allow you to monitor the temperatures. If you don't have it, you should be able to download it from Gigabytes website.

I suggest you place the system under load for a while then check the temps.
  • 0

#8
DarkGuard

DarkGuard

    New Member

  • Topic Starter
  • Member
  • Pip
  • 9 posts
Thanks again. I do have EasyTune. I ll install it and watch for my temperatures.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP