Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Hard disk drive doesnt not pick up total capacity


  • Please log in to reply

#1
mrtypr

mrtypr

    Member

  • Member
  • PipPipPip
  • 135 posts
Hello

I recently got a new system. New CPU, motherboard, RAM. I kept my old storage devices. My hard disk is a 250gig Seagate. But i have reformatted everything and re installed WINxp and IT only says its 137 gig. So my first impression was i needed to install the RAID controller driver. So i downloaded the Driver pre install files and put them on a floppy. I then proceeded to run windows setup with my Windows CD. I pressed F6 and it picked up and detected the new RAID controller drivers. I load XP and go to devive manager and under RAID controller it says its working fine etc. But when i go to Local disk from My Computer it still only says its 137 gig. IF i go to System Information, and look at the info from my hard disk drive it says 250gig.

I run my computer shop who installed the hardware. And they asked if i definently had service pack 2 installed. Which i do. I noticed in device manager that the system did not reconise the RAID controller. So i downloaded the files for the Raid Controller and put them on to a floppy. I ran windows Setup and pressed F6 as you do and installed the Raid Drivers. I did not proceed to install windows again though. I just exited. Then in devive manager it said that the RAID controller drivers were working fine. But as i see the total size of my Disk in My Computer it still says 130 gig. I even have gone to disk manager and it only has 1 partition there which is the 130gig one.

Does anyone know what to do here

Edited by mrtypr, 07 December 2007 - 10:40 PM.

  • 0

Advertisements


#2
Kelvin

Kelvin

    Member

  • Member
  • PipPipPip
  • 921 posts
Might be a corrupted sector(s) that make the sector unreadable, thus showing the disk size smaller.

Try running a chkdsk /f and reply with the results.

~Kelvin
  • 0

#3
mrtypr

mrtypr

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 135 posts
will do

But the guy at the computer shop did say there was an error on your hard disk. Like 2 bad sectors or something.

But before i got it upgraded i always had 250 gig
  • 0

#4
ViprXX

ViprXX

    Member

  • Member
  • PipPipPip
  • 172 posts
if you have winxp sp1 or sp2 installed then you might just need to go into your motherboards bios and set the hard drive to LBA/Large Mode. set it to Auto or Enabled depending on which option is available.

good luck
  • 0

#5
Kelvin

Kelvin

    Member

  • Member
  • PipPipPip
  • 921 posts
Might be when you were taking out your hard drive, it got corrupted. Don't know how that happens, but somehow it does. Happened to me once. Though that drive was pretty old already.

Try Vipr's tips first. If those don't work, then tell me. I'll get a fix for ya.

~Kelvin
  • 0

#6
mrtypr

mrtypr

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 135 posts
OK, i have run the check disk, and i ticked both options to fix straight away and scan for and try to recover bad sectors. It said it needed some windows files to perform the scan disk and needed to restart. So i went ahead. And it said at the end of the scan that the volume is clean.

I also tried the option of going into the BIOS and it was already set to auto. The capacity it was under "auto" was 250 GB. I changed it to large and the 250GB stayed the same but some of the cylinders etc changed. So i tried to run the PC with that setting. It did not like it and said "disk error press ALT CTRL DEL to restart" so i changed it back. So no fix... :)

To be honest of have a hunch its got something to do when i deleted the partition when trying to reformat the PC. But the guy at the PC shop said it shouldnt matter Service pack 2 should get it back....

Edited by mrtypr, 08 December 2007 - 02:43 AM.

  • 0

#7
Kelvin

Kelvin

    Member

  • Member
  • PipPipPip
  • 921 posts
I think you should send it back to the guy at the PC shop for a check again. It should show the correct size after being cleaned for bad sectors and changing the settings.. and it doesn't.

May I ask, how long was the warranty given to you? Is it still available to exchange?

~Kelvin
  • 0

#8
mrtypr

mrtypr

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 135 posts
Im not sure how long the warranty is, Its a Seagate 250GB 8 MB, ATA, 7200 RPM. I still have the receipt with it. I bought it with my orginal hardware with the computer on the 15/11/2005.

I also got more problems. I keep getting these blue screens of death while i play a game. i managed to write this one down i got one saying "Page_FAULT_NONPAGED_AREA" i asked a friend about it and he said to go to control panel, system, Advanced, performance, advanced again and adjust the virtuol memory range. Which i noticed it was below the recommended range. THen i tried playing the game again i get another blue screen of death this time it says "DRIVER_IRQL_NOT_LESS_OR_EQUAL".

can anyone shed any light on any of these?
  • 0

#9
Kelvin

Kelvin

    Member

  • Member
  • PipPipPip
  • 921 posts
Microsoft's view on this problem:

Stop 0x000000D1 or DRIVER_IRQL_NOT_LESS_OR_EQUAL
The Stop 0xD1 message indicates that the system attempted to access pageable memory using a kernel process IRQL that was too high. Drivers that have used improper addresses typically cause this error.

Interpreting the Message
This Stop message has four parameters:

Memory referenced.
IRQL at time of reference.
Type of access (0x00000000 = read operation, 0x00000001 = write operation).
Address that referenced memory.
Resolving the Problem
For additional troubleshooting suggestions that apply to all Stop errors, see "Stop Message Checklist" later in this appendix.

Stop 0xD1 messages can occur after installing faulty drivers or system services. If a driver is listed by name, disable, remove, or roll back that driver to confirm that this resolves the error. If so, contact the manufacturer about a possible update. Using updated software is especially important for backup programs, multimedia applications, antivirus scanners, DVD playback, and CD mastering tools.
For more information about Stop 0xD1 messages, see the Microsoft Knowledge Base link on the Web Resources page at http://www.microsoft...ts/webresources. Search using keywords winnt, 0x000000D1, and 0xD1.

Hope this piece of info helps you.

~Kelvin
  • 0

#10
mrtypr

mrtypr

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 135 posts
Well these blue screens are making me think there is something wrong with my hard drive.

But on the good side of things, i have managed to merge my 2 partitions and i now have a 250gig hard drive.

Only thing the first time i tried to do it it said error and i had to reboot. I tried it again and it completed it, Now i think it thinks it as 2 operating systems because the first one did not finish. On every boot up it asks me which Windows XP to select. Which it is 2 Windows XP it gives me to choose from and only 1 of them works. Any easy way to fix this? Or i might just re format my pc again or do a windows repair.

I really hope giving my system alot more space will fix the blue screens. Or i might need to get a new one if its the hard drive causing these problems...
  • 0

#11
Kelvin

Kelvin

    Member

  • Member
  • PipPipPip
  • 921 posts
Oh. The one is easy. Though, you'll need to be careful.

Select Start > Run > msconfig

Go to the tab 'BOOT.INI'.

Scroll down to [operating systems].

Look for the working one and select 'Set As Default'.

Your computer will start up with that one, unless you select F8. I don't think it will affect you if you leave it. Though, I'm not sure whether it can be removed. I'll check around later.

~Kelvin
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP