Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

External Hard Drive


  • Please log in to reply

#1
angieinkorea

angieinkorea

    New Member

  • Member
  • Pip
  • 7 posts
I used your site last year and I was very impressed with the help I received!
I now have a new problem :)

I have an External Hard Drive, and I use it daily. I have used it on many different computers and never had an issue to use it on my computer afterwards.
Tonight my friend came over and we plugged the HD into her comp, and we were able to look at some files, and transfer some to hers.
Then we turned off her comp and my HD, and afterwards I went to plug it into my computer. I got a message saying that the USB device was not recognized...?!?!
I tried it on another computer and the same thing happened.

Here are some things I have noticed:
1. The USB port does recognize my Hard Drive
2. Under "my computer" the drive is called "Local Drive H" when it is usually the name of my External HD...
3.When I click on the Local Drive H, there is nothing in it!
4. When I want to "safely remove device", the computer does recognize that I have the External HD plugged in
5. IN the Local Drive H, I clicked on properties and I found that the External is recognized and it says that it is working normally...??
6. Every once in a while there is a clicking noise that was never there before
7. I tried plugging it into different USB ports, and I even tried different cables and it is still the same. I also tried restarting my comps, and also leaving the External HD turned off for a while...still nothing..

I have thousands of files, and most are backed up apart from some photos and music from the past 2 months...so I hope this can be easily fixed, or I can at least get those files off..

Thanks!
  • 0

Advertisements


#2
angieinkorea

angieinkorea

    New Member

  • Topic Starter
  • Member
  • Pip
  • 7 posts
Also I get this message: "No drivers are installed for this device"
  • 0

#3
kenichi_kun

kenichi_kun

    Member

  • Member
  • PipPip
  • 13 posts
Anyonghasaeyo Angieinkorea, what kind of an external hard drive is it? I also had a similar problem like yours like 3 years ago. I just tore my external hard drive apart and installed in into my computer with and I was able to see all my files, I went ahead and burnt all of it onto dvd-r's and reformatted the hard drive and put it back in the external case. It now works just fine, don't know what could have caused the problem but I was able to get my files back. You can try what I did but if you are new to pc hardware then don't tear your external apart. Well good luck. Fighting!!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP