Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Multiple hard drives causing me grief!


  • Please log in to reply

#1
notquiteanexpert

notquiteanexpert

    Member

  • Member
  • PipPip
  • 17 posts
Hi Guys,

I am having problems with a new PC I've bought. I'll try to explain the situation as best I can, so hopefully it all makes sense.

In my old machine, I had 2 IDE hard drives installed. The master HD had the Operating System (Windows XP Home) installed, with the slave just used as data storage and to install a few programs when I ran out of space on the master.

I just bought a new machine that came with a SATA drive, and asked the computer store to also install my 2 old IDE drives such that I could access my data. They installed them (as IDE master & slave), but when I go to boot up the system, it tries to read from the master IDE instead of the master SATA!!

I installed Windows XP Home on the SATA drive....now on startup I get 2 options saying 'Do I want to boot Windows XP Home or Windows XP Home?'

I've tried going into BIOS and changing the hard drive boot sequence from the IDE and putting the SATA drive first, but as soon as I change ANY order of the boot sequence, Windows XP refuses to boot, saying that the boot device is invalid, or something like that. When I say ANY order, I mean the current boot order is setup as follows:
1. Master IDE
2. Slave IDE
3. Master SATA

I changed the order to:
1. Master SATA
2. Master IDE
3. Slave IDE
It didn't work. It said the same message about invalid boot device.

I then changed to:
1. Master IDE
2. Master SATA
3. Slave IDE
It STILL didn't work. It said the same message about invalid boot device.

I've also tried totally removing the Master IDE, such that I've only got a Master SATA and Slave IDE -> same message.
I've also tried changing the Slave IDE to Master IDE and just running with both Masters -> same message.....!!

I don't actually need the data on the Master IDE anyway!! Only the Slave IDE. How can I get around this....? What am I doing wrong!!!??

Putting the boot order back to the original way that works, I can't even format the Master IDE drive (even though Windows appears to be booting from the SATA drive). Once in Windows, I open command prompt and try to format c: (master IDE). It goes through the whole format 0% -> 100% but then says a message saying cannot format type or something like that. It is partitioned to NTFS.

Basically, all I want is follows:
- Windows installed to Master SATA and system booting from it.
- Slave IDE so I can access my data storage.

I don't mind reinstalling Windows if that is what it is going to take!!

Please help somebody!!

Oh, and while I've got you, I've also got a DLINK wireless adaptor (PCI) installed in the new PC that windows refuses to detect. I've tried taking it out and booting up Windows, then putting it back in and booting up windows. I don't know where the driver CD is, but downloaded drivers from the net. The green light on the hardware is flashing, indicating that it is installed correctly on the motherboard. Any ideas?

Thanks guys - you are life savers.
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Easy solution:

Unplug all IDE drives. Set BIOS to boot from CD as first device, your SATA drive as second device. If an option is available entitled "Try Other Boot Devices" (or similar wording), set this to No.. Reinstall Windows by wiping the SATA drive and removing all partitions via your XP CD.

When Setup is complete and you're back at the desktop, shut it off and plug your IDE drives in. Computer should now no longer attempt to boot off the wrong drive because you've specifically told it to boot off one specific drive. Most computers will try to boot off anything they can get their hands on and left to its own devices, a computer will almost always end up booting off the wrong drive unless you intervene.

As to the wireless adaptor - shove it in another PCI slot.
  • 0

#3
notquiteanexpert

notquiteanexpert

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Hi Niel,

Thanks for that advice.

When I get to the stage of putting the IDE drives back in, how should I arrange the jumpers? i.e. should I set up one IDE drive as master and one as slave, or should both be slaves etc.

As I said in the first post, I really only need one IDE drive, not both. If I am going to only install one, should it be a master or slave?

Thanks!
  • 0

#4
notquiteanexpert

notquiteanexpert

    Member

  • Topic Starter
  • Member
  • PipPip
  • 17 posts
Hi,

Please disregard last. I did what you said and it worked perfect!

Now for the wireless adaptor. Unfortunately I only have the one PCI slot. Well, I actually have two, but the other cannot be reached because I've got 2 linked graphics cards and one of them is blocking the slot (looks like a heat sink that is blocking the slot)....

So, any other ideas?

Thanks heaps.
  • 0

#5
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
If you have access to another computer (or a friend's computer), try your card in their computer. If it doesn't work there, replace the card or you can buy a USB wireless adaptor instead.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP