Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

RAM problem

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 4 posts
Today i purchased a 1gb DDR2 for my XP computer. After putting it in the computer would not start and the power supply LED light was blinking.
I removed the RAM but the problem continued. Is there anything that I can do to fix this. The power supply will not start and the LED keeps blinking when connect to power.
I cannot use the computer at all for now, but it's a Compaq Presario running Windows Xp and it's about 3 years old.

Thanks for any advice
  • 0




    Member 5k

  • Technician
  • 7,062 posts
You most likely loosened other components when putting the new RAM in. Check all cables and power plugs to make sure they are firmly seated. Make sure the CPU was not bumped and is now slightly loose, ditto for any PCI cards.

If this is a laptop, make sure you are putting the ram in correctly and fully seating it.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP