Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Card Reader Monitor


  • Please log in to reply

#1
Strat942

Strat942

    New Member

  • Member
  • Pip
  • 2 posts
I keep getting a program not responding message for "card reader monitor for 9360 4.5 slot" when shutting down windows. After clicking "end now" I can continue to shut down windows. This doesn't happen all of the time but quite often.

Also, I can't eject a USB flash drive because Windows says it is being used even though no known programs are accessing it. My other Windows XP computer has an icon in the bottom tool bar for ejecting devices, but the computer in question does not display this icon.
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Windows will not let you "eject" USB flash drives because there is nothing to eject. You need to stop the device which does the same job.

If the "Safely Remove Hardware" icon is missing, it can normally be restored by downloading the latest chipset drivers for your main board. You'll find these on the site of the people who made it.
  • 0

#3
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
Here are some tips on getting the "Safely remove hardware" icon back in the System tray of the TaskBar.

http://www.raymond.c...-hardware-icon/

With your USB flash drive installed, open Device Manager, select the flash drive, click Properties, then have a look at the policies tab.

Your choices are Optimize for Quick Removal and Optimize for Performance.
When Performance is selected, the "Safely Remove Hardware" icon is supposed to
show, and when Quick Removal is selected, the icon won't show. You could try selecting
Quick Eemoval and Apply it then select Performance and Apply it, see if that brings it back.


Another possibility is within Windows UPnP and the only workaround is to remove it.

Start > Settings > Add/Remove Programs
Add/Remove Windows Components > Networking Services
Uncheck 'UPnP User Interface'

Saw one post where checking 'UPnP User Interface' fixed this so it's possible that just changing the status fixes it, so you could try unchecking it, verify it's fixed then go back and check it again, see if it remains fixed.

Here is a work around

Right click an empty spot on your desktop and create a new shortcut and in the target area copy and paste the data in red

%windir%\System32\RUNDLL32.EXE shell32.dll,Control_RunDLL hotplug.dll


This will bring up the safely remove hardware dialog box.
  • 0

#4
Strat942

Strat942

    New Member

  • Topic Starter
  • Member
  • Pip
  • 2 posts
Thanks! I changed the setting to "performance" and now I have the icon back in the toolbar and can safely eject the device.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP