Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

bsod but only after sp1 or sp2 (xp home)


  • Please log in to reply

#1
stevesjunkshop

stevesjunkshop

    New Member

  • Member
  • Pip
  • 1 posts
Greetings. This is my first post and I have a real head scratcher.

I am having an issue with an older laptop - A Sony Vaio FXA32. This Sony laptop operates on a VIA KT133 chipset and had XP Home originally installed. It was given to me by a neighbor and I have turned it into a project. When I received it there were no CDs, no AC adapter, and it had a damaged LCD display. Using a generic Kingston laptop power adapter and an external monitor I discovered that the laptop did function. While the original XP Home operating system would boot it was not very stable. A chkdsk turned up many cross linked files. Without the restoration disk set, I created a DOS based boot floppy. I could do this because the 15gb hdd was partitioned into a 6gb primary partition with fat32 and a 8gb ntfs secondary partition. Using the Win98se based floppy I booted the laptop and ran a surface scan of the hdd. There were no surface defects found.

Next, I formatted the hard drive and installed win98se. Over several days the laptop operated fine. During that time I downloaded and installed several patches including VIA and Microsoft patches.

Next, I formatted and installed win2k. I patched this operating system with sp4 and ran this os for a number of days without any failures. By this time I was made an offer of all the required parts to repair the laptop. Because the price was reasonable I accepted and waited for the parts.

Next, I tried Ubuntu linux which failed to install. It did not crash but more or less just stopped installing. Because I was just jumping around to various operating systems I did not try too hard to get linux into this system.

Finally, I tried to install XP Home w/sp2 off of a Dell CD. While the installation went fine, the laptop suffered bsod failures. The system would fail within a few seconds of the mouse pointer displaying. The error message was a MACHINE_CHECK_EXCEPTION 0x0000009c. I was remiss at this time because I did not record the other four parameters.

Now, before I continue with the saga, I have read many web pages stating that this error - 0x0000009c - indicates a hardware failure. But, I do not believe this to be the case and you too may see my reasoning.

With that install being a failure, I borrowed yet another Dell XP Home CD. This one did not have any service packs. It was obviously an older CD. The installation went smoothly and the operating system was working fine but it was complaining that activation was required. Again, I experimented with the os for a day. I installed the Sony specific drivers from their web site and installed around fifty critical patches from Microsoft. But, without the computer being activated I could not install either sp1 or sp2. I did find the sp1 executable on the MS web site, download it, and installed it, and back came my 0x0000009c errors. Notice the pattern if either sp1 or sp2 are installed the os crashes.

At this point I received the parts I was expecting for the laptop. The repairs went smoothly enough and added another 128meg memory chip bringing the installed memory up to 256megs. I ran memtest86 and encountered no memory failures. I also have speedfan installed. It shows that the hdd is running fairly warm - around 50 degrees C but the CPU comes in around 25 degrees C.

So, the os - xp home - goes in from the Sony restoration disks without the need for activation. After the Sony patches I put in sp2 and the 0x0000009c failure returns again. This time I try to boot into safe mode but the os crashes just the same.

I then began another wipe and install of winxp from the Sony restore disks but this time with sp1 installed instead of sp2. It fails much the same as did sp2. My attempt to run sp1 in safe mode is a little more successful. I was able to boot into safe mode but it crashed again with the 0x0000009c failure about five minutes after starting to remove sp1.

Three days ago I wiped the hdd again, reinstalled the os, and patched it with everything I could except the service packs. It has been running continuously since that time without a single failure. Last evening it was suggested to me that I attempt sp1 again but after the install that I boot into safe mode and disable every possible service. If the laptop operates normally, I should start the various services one at a time until I determine the service causing the crash. This seems reasonable to me and it is my next try to get this os up to date.

So does this sound reasonable? What additions to the os were made by MS at SP1 that may be getting me into trouble? Does anyone have any additional suggestions?

I have typed this entire document on the laptop.

Steve

And a happy new year to all.
  • 0

Advertisements







Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP