Jump to content

Welcome Guest to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Feel free to browse the site as a guest. However, you must log in to reply to existing topics or start a new topic of your own, and enjoy all this forum has to offer. Additionally, if you can assist another member by sharing your knowledge, please post a reply! Best of all - Registration and all assistance, is FREE! Learn more about How it Works. Infected? Malware Cleaning Guide. What are you waiting for?
Create an Account Login to Account

Vista says i'm not an administrator but im the only account?!


  • Please log in to reply

#1
Jen :-)

Jen :-)

    New Member

  • Member
  • Pip
  • 2 posts
I have a lap top with windows vista on it. I am the only account and when i go into the user accounts it lists my account as the only account and an administrator. My norton's anti-virus recently ran up. I tried to download spybot and adaware. I ran spybot and it found problems. But now it won't let me delete the problems because it says i must be an administrator.

Please help
Jen<3 :)
  • 0

#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
This may be caused by an older version of Spybot because this program does work with Vista after a certain version, 1.5.1.18.
  • 0

#3
PsychPosse

PsychPosse

    Member

  • Member
  • PipPipPip
  • 322 posts
Even though you log in as an Admin with the account you have, it has limits. This is something Vista did to protect you from yourself. In other words, you don't have full administrator priveleges.

You can log on as a full admin a few different ways. One way is to simply unhide the true admin logon in a cmd.

click the start menu.
In the bottom search bar type cmd (don't hit enter)

cmd will show in the list on top .. right click on it and click to run as administrator

the command panel will open
type this command exactly as it appears here.. or just copy and paste it in the cmd panel

net user administrator /active:yes

hit enter and it should tell you it completed successfully.

close the cmd panel and log off of windows.

When you log back on you should have a new Admin log on.

Log on as admin and try to run your program that way.

It might be a good idea to keep your regular user logon and use that for normal functioning.
You might also want to create a password for the admin logon and only use that for technical purposes.

Hope that works for you.

Also, when you do log on as Full Admin, it will be like the very first time you ever logged onto your computer. You will have to set up the profile, desktop, settings and all that good stuff. It is just a separate account and it has it's own settings. You may also have to approve firewall settings to get online, etc.. All of your programs will still be in the program list. All of your pictures, music, documents etc. will be under your other account profile, but you can access them as admin. So don't panic if you log on as admin and you can't find your documents etc..

Edited by PsychPosse, 06 January 2008 - 07:14 PM.

  • 0

#4
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts
I found that with user account control turned off I sometimes do not have admin. ability. turning tis on (in user acounts in control panel) gives me admin. rights but I have that pesky pop up to deal with
  • 0

#5
PsychPosse

PsychPosse

    Member

  • Member
  • PipPipPip
  • 322 posts
the UAC popup is the microsoft way of protecting you from yourself.
Your admin rights are still limited and the only way I know around it is to actually enable the admin account and login as full admin.

I don't see UAC popup warnings anymore. :)


Did you change your screen name? or do you have two accounts?

Edited by PsychPosse, 06 January 2008 - 04:43 PM.

  • 0

#6
hfcg

hfcg

    The hippie freak computer geek

  • Member
  • PipPipPipPipPip
  • 2,496 posts
I followed the steps and WOW. Thank you for sharing this!
  • 0

#7
JMGT25

JMGT25

    New Member

  • Member
  • Pip
  • 1 posts
Thank you so much for that help in turning on the admin account. I turned it on and was able to install the program. But I would like to back to my old account now. Can you please instruct me in how to turn off the admin account. I tried from control panel and it wont let me. Can you please tell me how to do it from the cmd prompt. Also, what directory do i have to be in, in the cmd prompt. Thanks a lot, it would be grealty appreciated.
  • 0

#8
PsychPosse

PsychPosse

    Member

  • Member
  • PipPipPip
  • 322 posts
Next time please start your own thread, as this one belongs to another user.

However, follow the above command line instructions and simply put No instead of Yes

ex. net user administrator /active:no

That will re-hide your full admin logon.

Apparently you have your computer set to login automatically instead of password protected. To change that (I would recommend it if you want more security) go to the Start menu and in the search bar type netplwiz

You will see where you can check to require users to use a password. You could leave the full admin logon unhidden and just require a password for that logon as well, and still have auto logon with your regular user name. To get back to a log on screen, and your other user account just click the start menu and in the same list where you click to turn off your computer, select Log Off instead of Shutdown. You should be able to get back to your regular user account that way.
  • 0

#9
Jen :-)

Jen :-)

    New Member

  • Member
  • Pip
  • 2 posts
when i tried to bring up the hidden admin account it said that my access was denied :-(
  • 0

#10
PsychPosse

PsychPosse

    Member

  • Member
  • PipPipPip
  • 322 posts
When you run the cmd you must run it as administrator.

It is important when you type cmd in the search bar, in the start menu, that you do not hit enter to search for it or open it. Just type the letters cmd in the search bar and then look up on the top of the start menu and see cmd. There you will right click on it and select "run as administrator"

You should then be able to unhide the full admin log on as instructed.
  • 0

#11
jamez22

jamez22

    New Member

  • Member
  • Pip
  • 1 posts
same question but i have windows 7 and i am trying to run codename panzers coldwar for the first time.
  • 0

#12
RandomMe

RandomMe

    New Member

  • Member
  • Pip
  • 1 posts
Try this...

Go inside Control Panel --> User Accounts --> You will see your account and see that it says "Administrator" even when it isn't acting like it...because as they said above "Vista is protecting you from yourself" So to change this click on "Change Your Account Type"

You will see two options, Standard (which is probably selected already) and Administrator, which is not. Click in the radio button (the circle) of administrator.

Thought it would allow me to change the type but when I selected it it graded out the "Change Account Type" button...but I hope it works for you or someone out there.
  • 0


1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Google (1)

As Featured On:

featured