Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

USB device not recognized on my laptop (XP home)


  • Please log in to reply

#1
drtjmich

drtjmich

    Member

  • Member
  • PipPip
  • 15 posts
I have a external USB hard drive (Maxtor Personal Storage 3100) that was was working fine with my laptop (XP Home). Now I get a message "USB device not recognized" with a little bubble window saying it malfunctioned and Windows does not recognize it..for assistance in solving this problem, click here. I have the same problem with another identical laptop here at home. I took the storage device to work and it works fine on my work computer (XP Pro).

At work all Windows updates are controlled but at home they are automatic loaded so I am wondering if a Windows update did this since I found this below on Windows website: (I tried what was here but could not find "StorageDevicePolicies" where they described)
I also contacted Maxtor and did what they suggested (which was uninstall all USB controller USB roothub and reboot)

Thanks in advance for your help,
Denise

SUMMARY
Your Windows XP PC may not recognize the removable storage devices that you connect to your PC. However, the other USB devices may work normal.

CAUSE
This is not an issue and a security feature added in Service Pack 2. When you connect any removable media device to a computer that has Microsoft Windows XP SP 2 installed, and the solution provided in the following MS Kbase article may not resolve the issue:
http://support.micro...om/?kbid=823293

RESOLUTION
Now, a new feature has been added to Windows XP SP 2, which will prevent the write operations to USB block storage devices, such as memory sticks. When this option is enabled, the devices function only as read-only devices. To enable this option, modify the following registry entry:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\

Double-click "StorageDevicePolicies" and change the DWord value to 1.

0 - Disabled
1 - Enabled
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
If you do not have the StorageDevicePolicies key, create it through the Registry Editor by making a new key and setting it to whatever you need. If no key exists, whatever the default value is is used instead.
  • 0

#3
drtjmich

drtjmich

    Member

  • Topic Starter
  • Member
  • PipPip
  • 15 posts
What is a Dword?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP