Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

XPpro only sees half the drive size


  • Please log in to reply

#1
Fygar

Fygar

    Member

  • Member
  • PipPip
  • 36 posts
My XP home with a WD 250gb drive crashed the other night, and after repeated tries at Recovery, I decided it was a good time to install XPPro instead. From another drive with XPpro on it,and using the WD as a slave, I saved all my data files. I noticed then that Windows was reporting the size of the drive at only 130gb Then I did a low level format of the 250gb drive which at completion showed the 250gb size. With that done, I was going to use the XPpro disk management tools to partition and format prior to a clean install. Disk management tools only show the 130gb size!! What the heck is going on here? What can I do to get the 250gb back? Am I overlooking something really simple? Any and all advice is welcome.
  • 0

Advertisements


#2
Samm

Samm

    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Welcome to G2G Fygar

It sounds like you have the old 48 bit LBA problem. Basically, for a computer to recognise a drive larger than 127GB, both the bios and the OS have to support 48 bit LBA translation. I'm assuming is your case, the bios does (however, if you've currently got the drive attached to a different computer, then you may want to check that the bios is recognising the full size). If the bios is fine, then the problem is with XP. Which service pack do you have installed?
  • 0

#3
Fygar

Fygar

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
Same computer, I just had an old 20mb drive laying around, so I put it in as the master and installed XPpro. Thank you for the question though, because I checked with windows update and found that it needed SP2. Doing that update now. Hoping that that will make the whole drive usable. It makes sense, because what was on the drive before was XP Home SP2 and it made use of the whole drive.
Thanks for the thought starter!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP