Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works


  • Please log in to reply



    New Member

  • Member
  • Pip
  • 2 posts
I installed 2 memory chips at 1024 Mb each to replace my old 256 MB and now a slew of problems has arisen...coincidence? For one, my cd drive is all of the sudden missing (E drive), internet explorer is missing (yet it still shows up in the control panel programs), and I think I messed with the registry and now its all a mess...can anyone help me?
  • 0




    Tech Staff

  • Technician
  • 16,645 posts
Hi linsteve...

Have you tried restoring your computer to an earlier time using the System Restore feature? If it's a registry problem, that will usually straighten things out.

  • 0



    Member 5k

  • Technician
  • 7,062 posts
After doing the System Restore, since this started after the memory upgrade, remove the 2GB of memory, put the 256MB back and see how the computer behaves. If better then install 1 stick of memory and try it. If ok, install the other. That way you will be able to tell if one of the new sticks of memory is defective, which does happen unfortunately.
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP