Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

laptop turns on but wont load windows


  • Please log in to reply

#1
planebuilder

planebuilder

    New Member

  • Member
  • Pip
  • 4 posts
Hi folks, I am new to this board, but i need your help. I have a compaq presario v2000 running windows xp and a celeron processor. Over the last few mos it will turn on and then just a blank screen...I can hear the fan or something running and the power light is on, but windows does not load. For a while it only did this occasionally, but recently it has done it just about every time you turn the computer on. I have found that if i remove the main battery and then push the battery back on it will start every time after doing this. Any help will be appreciated...thanks in advance.


louis
  • 0

Advertisements


#2
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Battery's probably shot. Shouldn't have to remove the battery every time.
  • 0

#3
planebuilder

planebuilder

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
thanks...might be...but it holds a charge and will run for over an hour on battery alone. So, do you still think a bad battery or maybe somthing else? Thanks again
  • 0

#4
Neil Jones

Neil Jones

    Member 5k

  • Member
  • PipPipPipPipPipPipPipPip
  • 8,476 posts
Could be a bad contact between battery and laptop but short of gently cleaning them with tissue this sort of issue tends to only get worse with time.
  • 0

#5
planebuilder

planebuilder

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
thanks a bunch....new battery it is. Have a good one
  • 0

#6
planebuilder

planebuilder

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
cleaned battery contacts best I could....seems to have fixed the problem. I have turned it off and on like 20 times over the last couple of days. Thanks guys.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP