Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Need help please.....


  • Please log in to reply

#1
marlonjohn

marlonjohn

    New Member

  • Member
  • Pip
  • 3 posts
hello, well im new to this forum.. so i do not know if im in the right category.

well i have just bought my new " ATI RADEON 9800 PRO (GECUBE-says on box)"
ived installed all the drivers and the lastest directx.
well the problem here is when i installed "need for speed underground 2" the game is good and fast graphics.. the only thing thats bad is when you play the game. it goes really really slow like real bad. ived tryed running other games such as Halflife2, unreal tournament 2003, Need for speed underground1, (steam) games like, Day of defeat and counterstrike. all theses games work real good! but this is the only game that is real slow...
ived had this problem with my other card.. ( geforce 2 )
it ran need for speed underground 1 real slow like as the need for speed underground 2 is now... but now the game is working good except for nfsu2... so i do not know what happend. PLEASE HELP!!

INFO:

power supply: 300 or 350wt
COMPUTER: AMD athlon 1.7
RAM: 512mb
CARD: ATI GECUBE RADEON 9800 PRO

well i hope this works out good from the feedback...
thanks

marlon john

Edited by marlonjohn, 21 April 2005 - 06:55 AM.

  • 0

Advertisements


#2
Darkmocha

Darkmocha

    Member

  • Member
  • PipPip
  • 36 posts
Perhaps you could try turning down the details. You might have them cranked up for your other games which aren't up to the level of NFS2.

Also the first thing to try with all video cards is to update the drivers. Update those and see how that goes.
  • 0

#3
marlonjohn

marlonjohn

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
hello again, well ived tryed putting the graphics down but it still goes slow...
and ived got the lastest updates but im not sure if there the right one. ived tryed the ati cd and this website link... " https://support.ati....dge&folderID=27 " then i downloaded the first link, (1 package) "
if the link dosnt show the thingo here it is...

1: www.ati.com / drivers & software / Windows XP Drivers & software / ------
radeon / CATALYST 5.4 Windows XP - Driver Download / then package one ( high speed )

well thanks for replying back hope you can help me out...
bye

marlon john

Edited by marlonjohn, 22 April 2005 - 02:14 AM.

  • 0

#4
audioboy

audioboy

    Member

  • Member
  • PipPipPip
  • 857 posts
just to make sure, are you removing the old drivers first?
with catalyst, go to add/remove programs, then click the ATI software uninstall utility. it will remove all drivers. reboot, then cancel out of the found new hardware wizard. then install the catalyst package that you have downloaded.
  • 0

#5
marlonjohn

marlonjohn

    New Member

  • Topic Starter
  • Member
  • Pip
  • 3 posts
hello audioboy... well i just did it all...

it goes a little little little little better but still very slow...
i did everything u said.... hmms

im just wounding can it be my computer that is making it slow..
ived got a 1.6 or 1.7 amd...

thanks for trying to help
bye

marlon john

Edited by marlonjohn, 22 April 2005 - 04:32 AM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP