Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Can't recognize Drive Size!


  • Please log in to reply

#1
Robbie S

Robbie S

    New Member

  • Member
  • Pip
  • 5 posts
I recently upgraded my computer with a new motherboard. The computer now has an AMD Athlon 64 X2 Dual Core processor on the motherboard. The BIOS is an Ambios Version 0301; the build date was 7/31/06. I am running Windows XP Professional.

Here is my problem: Prior to upgrading the motherboard, the computer wouldn’t recognize anything larger than 34 GB on the hard drive. I have two Western Digital IDE drives in the computer: the first is a WD600BB 60GB (running the operating system) and the second is 120GB WD1200JB, which is just for storage. Since upgrading the motherboard and the BIOS, the computer is still not recognizing the larger hard drive sizes!

Since I'm a bit cowardly and it was easier to start first with the "slave" drive, I tried reformatting the 120GB storage drive by writing zeros to the drive (on advice from Western Digital), but it still only sees 34GB when I go to partition it. The weird thing is that that Western Digital Diagnostic software seems to see the correct size, but neither Windows XP nor the BIOS sees the full size. I've looked at the jumper settings and don't see anything there that I think could restrict the capacity.

I’m wondering if I need to change something in the BIOS. The BIOS settings for both hard drives are as follows:

Size: 0 MB
LBA Mode: Supported
Block Mode: 16 Sectors
PIO Mode: 4
Async DMA: Multiword DMA-2
Ultra DMA: Ultra DMA-5
SMART Monitoring: Supported

Type: [Auto]
LBA/Large Mode: [Auto]
Block (Multi Sector Transfer: [Auto]
PIO Mode: [Auto]
DMA Mode [Auto]
SMART Monitoring [Auto]
32 Bit Data transfer [Enabled]

I am very frustrated and any advice or suggestions would be greatly appreciated.

Thanks (in advance) very much!
  • 0

Advertisements


#2
GeekTech

GeekTech

    Banned

  • Banned
  • PipPip
  • 50 posts
Hello,
Is your jumper set like this:
:::[]:
If you can understand that :) hehe
um if it is then I would guess it's a setting in your bios, do you have the paper that came with your hard drive? it should tell how many sectors, etc. to enter in in the bios, I haven't had any experience with your bios so I don't know the lay out, but from my experience with other BIOS's and WD hard drives, it took me a while to get my comp recognizing the full capacity of a WD 80GB that I had If I remember right then I had to update my bios, (maybe you can fine a newer bios version for your's) but that was about 4 years ago so I'm not sure.

GeekTech

Edited by GeekTech, 27 January 2008 - 11:43 AM.

  • 0

#3
Seltox

Seltox

    Member

  • Member
  • PipPipPip
  • 254 posts
How are you partitioning them? If you are using a really old program (old versions of fdisk - like what i have *cringes* - only recognise around 60gb. So I have to partition my drives solely on %'s, having two 200gb drives).

And also what GeekTech says is important. Setting your jumper in a certain place can limit the drives capacity.
  • 0

#4
SRX660

SRX660

    motto - Just get-er-done

  • Technician
  • 4,345 posts
Something you should think about is that if you are running XP with the FAT 32 file system, it will only see 32 gigs of any hard drive. This is a limitation of Windows XP. You can convert your system to NTFS file system and it will then see the rest of the drives unless there is a DRIVE OVERLAY PROGRAM installed on the drives.

http://support.microsoft.com/kb/186057

If you convert to NTFS you will have to format the rest of the drives as different partitions than your main "C" operating system drive.

You can start all over and remove any drive overlays on a drive then install XP after formatting as NTFS. You should then be able to have a single large drive this way.

SRX660
  • 0

#5
Robbie S

Robbie S

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
Both drives are using NTFS..I was able to check, using the Western Digital diagnostics software.
Thanks

Edited by Robbie S, 27 January 2008 - 02:06 PM.

  • 0

#6
GeekTech

GeekTech

    Banned

  • Banned
  • PipPip
  • 50 posts
So did you get this figured out? if not let me know and I'll try to help

GeekTech
  • 0

#7
Robbie S

Robbie S

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
No--not yet-- I've got to check the jumpers and cable, I guess-- I also tried contacting WEstern Digital Tech Support, but they haven't responded...(they are soooo frustrating!). I'm going to open up the computer today and check out the jumpers and cabling-- I'll let you know and thanks--

Robbie
  • 0

#8
Seltox

Seltox

    Member

  • Member
  • PipPipPip
  • 254 posts
Yeah, if the jumper is in the slave position, it will be limited to 32gb (on MY harddrive at least). Usually there will be a sticker on your hdd that will tell you the different positions and what they do.

Good Luck.
  • 0

#9
Tyger

Tyger

    Member 2k

  • Member
  • PipPipPipPipPip
  • 2,896 posts
You may have a jumper setting that limits the amount of drive space so you can use larger drives on older machines. If so you would need to change that setting to see the whole drive. You could format the remainder of the drive as a new partition or possibly expand your existing partition to the whole drive.
  • 0

#10
Robbie S

Robbie S

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
That took care of it! The jumper settings weren't right on the slave drive.... I changed them and now the Bios is recognizing the full size of each drive. I wrote zeros onto the 120GB slave drive and its fine now. I will have to eventually do the same with the master drive. Is there a way to add a new partition for the remaining space, without losing everything already on the drive?

Thanks again everyone for your help!

Robbie
  • 0

#11
Seltox

Seltox

    Member

  • Member
  • PipPipPip
  • 254 posts
If you have unused space, it should be easy to make a partition using some programs. GParted, fdisk, Partition Logic, Partition Magic, for example.
  • 0

#12
Robbie S

Robbie S

    New Member

  • Topic Starter
  • Member
  • Pip
  • 5 posts
I got it with Diskmgmt in XP Pro -- added a partition and so now I've recovered all my hard drive space on both drives! A happy Ending! Thanks!
  • 0

#13
GeekTech

GeekTech

    Banned

  • Banned
  • PipPip
  • 50 posts
Great to hear that have a great day. :)


GeekTech
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP