Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Delay bringing up open file dialog for all programs


  • Please log in to reply

#1
Rüsh

Rüsh

    New Member

  • Member
  • Pip
  • 4 posts
When I try to open a file on ANY program I use, I get a delay of about 15 seconds. This only happens the first time I try to open a file on any program, on the second try and every one after it opens like normal. When I exit a program, and re-load it, I go through it all again. I have spent the last 3 months trying to figure it out but I can't find anything out of place. I was thinking it might be a registry problem but I don't know much about looking through the registry.

Any hellp would be appreciated and if anyone needs more information I would be happy to oblige.

Thank you
  • 0

Advertisements


#2
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
This can sometimes be caused by a corrupted iconcache.db file in

C:\Documents and Settings\youruserid\Local Settings\Application Data

You can delete or rename it to something like iconcache.db.old. XP will recreate it as needed.

You will need to show all files in Folder Options:

Control Panel / Folder Options / View tab.

Select "Show hidden files and folders"
Uncheck "Hide extensions for known file types"
Uncheck "Hide protected operating system files (recommended)"

  • 0

#3
Rüsh

Rüsh

    New Member

  • Topic Starter
  • Member
  • Pip
  • 4 posts
Thank you for the reply, I tried your recommendation and unfortunately that did not fix the problem, I appreciate your input though.
  • 0

#4
Ztruker

Ztruker

    Member 5k

  • Technician
  • 7,065 posts
How does it behave if you boot to Safe Mode with Networking? If better then something is starting at boot that is causing the problem. Try the following:

First, physically disconnect from the Internet to prevent a malware infection while your Anti-virus and/or Firewall are disabled in the following steps, then do a normal boot:

Click on Start then Run, type msconfig and press Enter.
Click on the Startup tab and disable everything (I mean everything).
Do a regular boot, see if it runs normal.
If yes then use msconfig to enable several items at a time till you find the culprit.

If no, click on the Services tab. Check the Hide All Microsoft Services box then click the Disable All button.
Again, do a regular boot, see if it runs normal.
If yes then use msconfig to enable services till you find the culprit.

Once you've found the culprit, uninstall it or find out how to eliminate it from your system. Simply disabling it in msconfig is a temporary fix at best.

Reconnect to the Internet when your AV and firewall are active again.

This can also be caused by a shell extension. We can look at that next if necessary.
  • 0

#5
c5nest

c5nest

    New Member

  • Member
  • Pip
  • 2 posts
I experienced the same open file delay after installing a high-end embroidery program (similar to CAD).

The delay affected all Adobe software (CS3/CS4) and a file manager (Directory Opus) significantly, but did not seem to affect Office 2007 as badly.

Renaming the iconcache.db file solved the problem.

Thank you so much Geeks to Go!
  • 0

#6
Broni

Broni

    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Rüsh
Do you have indexing on?
Also...
Please, post some computer info:
- processor type, amount of RAM (hold Windows key, hit Pause/Break key)
- hard drive size/free space (open "My Computer", right click on hard drive letter, click "Properties")
  • 0

#7
c5nest

c5nest

    New Member

  • Member
  • Pip
  • 2 posts
I am glad you asked about indexing: I usually turn it off as it can slow down things.

This system is fairly new, and I had forgotten to turn off indexing.

System details:

Processor: Duo E8500 3.16 gHz 3.0 GB RAM
Drives: 150 GB (125 Free) & 200 GB (150 Free)

Unfortunately, renaming the iconcache.db was only a temporary fix. The open file delay is BACK!

Today I will try to contact the embroidery software company to see if they have a clue...
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP